1. 4 months ago

    whatwhat1

    Feb 10 31110V

    We are currently at a competition and we are having some problems with or drive train. Currently we are running a 4 turbo motor with no extra gears. We use a chain and sprocket for our back wheels but everyone wheel has an individual motor. Right now our robot will run full speed autonomous with no problems, but once driver control starts after 5-10 seconds the drive train will stall. This hasn't happened in practice and the robot doesn't stall in autonomous. We also have a power expander with two motors in ports 2 and 3 and 2 motors in ports 7 and 8.
    Here is our code:

    task usercontrol()
    {

    int threshold = 5;

    while (true)
    {
    if(abs(vexRT[Ch3]) > threshold) // If the left joystick is greater than or less than the threshold:
    {
    motor[leftFront] = (vexRT[Ch3])/2;
    motor[leftBack] = (vexRT[Ch3])/2; // Left Joystick Y value / 2.
    }
    else // If the left joystick is within the threshold:
    {

    motor[leftFront] = 0;
    motor[leftBack] = 0;
    // Stop the left motor (cancel noise)
    }

    if(abs(vexRT[Ch2]) > threshold) // If the right joystick is greater than or less than the threshold:
    {
    motor[rightFront] = (vexRT[Ch2])/2;
    motor[rightBack] = (vexRT[Ch2])/2;
    // Right Joystick Y value / 2.
    }
    else // If the right joystick is within the threshold:
    {
    motor[rightFront] = 0;
    motor[rightBack] = 0;
    // Stop the right motor (cancel noise) }

    }
    motor[liftL] = ((vexRT[Btn6U] * 127)) - ((vexRT[Btn6D] * 127));
    motor[liftR] = ((vexRT[Btn6U] * 127)) - ((vexRT[Btn6D] * 127));
    motor[claw] = ((vexRT[Btn5U] * 127)) - ((vexRT[Btn5D] * 127));
    motor[intakeR] = ((vexRT[Btn8D] * 127)) - ((vexRT[Btn8U] * 127));
    motor[intakeL] = ((vexRT[Btn8D] * 127)) - ((vexRT[Btn8U] * 127));

    if(vexRT[Btn7U] == 1) // If button 7U (upper right shoulder button) is pressed:
    {
    SensorValue[solenoid] = 1;
    SensorValue[solenoid1] = 1; // ...activate the solenoid.
    }
    else // If button 7D (upper right shoulder button) is NOT pressed:
    {
    SensorValue[solenoid] = 0;
    SensorValue[solenoid1] = 0; // ..deactivate the solenoid.
    }

    }
    }

    4 motor turbo base = stalling = not a surprise. For this competition, most people in my area have 6-motor HS chassis.

    It probably works in auton because that is a very short and very controlled driving environment. Auton is probably stressing out the motors to start with (heating up the PTC internal circuit breakers), and then driver control under high-stress tournament conditions will handle the rest of the motor overload for you lickety-split.

    Also, the way you drive at home in your lab is MUCH easier on the robot than what happens in match play (IMO), even if it doesn't seem that way.

  2. biglesliep

    Feb 10 Answer Menlo Park, CA 1666

    4 motor turbo base = stalling = not a surprise. For this competition, most people in my area have 6-motor HS chassis.

    It probably works in auton because that is a very short and very controlled driving environment. Auton is probably stressing out the motors to start with (heating up the PTC internal circuit breakers), and then driver control under high-stress tournament conditions will handle the rest of the motor overload for you lickety-split.

    Also, the way you drive at home in your lab is MUCH easier on the robot than what happens in match play (IMO), even if it doesn't seem that way.

  3. whatwhat1

    Feb 10 31110V

    Thanks, we change all our motors in 35 min during the lunch break. Hopefully it will work now

  4. whatwhat1

    Feb 10 31110V

    Update: we replaced the base with 4 standard 393 motors and our base still stalled. We aren’t sure if the 4 motors base should do this. It didn’t do this our last or 2 competitions ago when we didn’t use turbo motors.

  5. ranOOm

    Feb 11 Ontario, Canada 2381

    @whatwhat1 Update: we replaced the base with 4 standard 393 motors and our base still stalled. We aren’t sure if the 4 motors base should do this. It didn’t do this our last or 2 competitions ago when we didn’t use turbo motors.

    Are the motors warm? Does it occur only on the field? what about practice?

  6. whatwhat1

    Feb 11 31110V

    The turbos seemed warm but I don’t believe our standard motors were warm. They also don’t do it in practice unless we get caught on a PVC pipe and try to get off it wrong.

  7. Carter

    Feb 11 Alabama 13907A

    Change the internal gearing of the motors to high speed instead of turbo

  8. 1961Uranium

    Feb 11 Georgia, United States Blitz Alliance 1961U

    @biglesliep 4 motor turbo base = stalling = not a surprise. For this competition, most people in my area have 6-motor HS chassis.

    It probably works in auton because that is a very short and very controlled driving environment. Auton is probably stressing out the motors to start with (heating up the PTC internal circuit breakers), and then driver control under high-stress tournament conditions will handle the rest of the motor overload for you lickety-split.

    Also, the way you drive at home in your lab is MUCH easier on the robot than what happens in match play (IMO), even if it doesn't seem that way.

    6 motor turbo 3.25 is also possible but that is with 3.25 in wheels.

  9. Blatherskite

    Feb 12 Austin TX 2158R

    Turbos always stall. last year at states my team lost all our matches because our drive kept stalling because of us having a turbo motor drive.

  10. whatwhat1

    Feb 12 31110V

    Yeah thanks guys. Someone we still managed to finish 2nd and get excellence award with our motors doing that and we only lost one round in qualifications. We are going back to our old 4 motor standard 393 drive train.

  11. briancole

    Feb 12 Utah 4270C

    @whatwhat1 Yeah thanks guys. Someone we still managed to finish 2nd and get excellence award with our motors doing that and we only lost one round in qualifications. We are going back to our old 4 motor standard 393 drive train.

    If you can, go HS. We run HS and the only reason it ever burned out was because we let our driver build and he stuck metal to metal friction all over the thing.

  12. Royal_Waffle

    Feb 12 Washington State 3249Z -- The Mechanics of Oz

    So, I've seen many teams use a 1:2 gear ratio on their drive, and it works fine. However, when I do it, the back right motor stalls after 30 secs to a minute of continuous driving. The other motors soon follow. Thinking it was the physical size of the gears, I replaced them with the two smallest chain gears I could find, and it still stalls. I still want a faster base, so what would be a better alternative? Here's my robot specs:

    4 motor torque drive; 1:1 chain drive (i experimented with a 1:2 today and it stalled)
    4 motor torque lift chain bar (12 tooth input to 80 tooth to 36 tooth output; idk how to annotate that)
    1 motor rollers; 1:1
    2 motor MG lift; 3:1

    btw I used a 1:1 chain drive during my recent comp and it never stalled

 

or Sign Up to reply!