Using Accelerometer with v5

  1. last week

    I am trying to use the 3-axis accelerometer with v5. My team has not gotten their v5 kit yet, but in the Vex Coding Studio API in c++ pro under the accelerometer class, the method for getting the value of the accelerometer only has either a percent type return of 0 to 100, or reading the analog value directly. How can these values be translated into actual acceleration units? It seems the API can only read the accelerometer as a direct analog value, not as an accelerometer.

  2. tabor473

    Oct 4 V5 Beta Tester OYES, WPI

    @caek I am trying to use the 3-axis accelerometer with v5. My team has not gotten their v5 kit yet, but in the Vex Coding Studio API in c++ pro under the accelerometer class, the method for getting the value of the accelerometer only has either a percent type return of 0 to 100, or reading the analog value directly. How can these values be translated into actual acceleration units? It seems the API can only read the accelerometer as a direct analog value, not as an accelerometer.

    Ya that is the case of using the sensors with the cortex as well

    Check out the product page here
    https://www.vexrobotics.com/276-2332.html#Description

    Both the overview and the Sensitivity are important to look at.

  3. Oh I see, so the sensor only gives analog values and we have to find the bias on the sensors to get the acceleration. Would it be safe to assume that the biases for all three axes are the same?

  4. tabor473

    Oct 7 V5 Beta Tester OYES, WPI

    @caek Oh I see, so the sensor only gives analog values and we have to find the bias on the sensors to get the acceleration. Would it be safe to assume that the biases for all three axes are the same?

    So in all likelihood 1 axis with have all of gravity as a bias and the other 2 axis will not. So they will have different bias values.

  5. Say hypothetically, that the accelerometer was used in zero gravity, would all the analog values read the same, or close to the same values?

  6. tabor473

    Oct 8 V5 Beta Tester OYES, WPI

    @caek Say hypothetically, that the accelerometer was used in zero gravity, would all the analog values read the same, or close to the same values?

    So the reason VEX doesn't just do the bias for you is that every chip has slightly different characteristics. The physical components just can't be manufactored precise enough for them to all be the same. This would be the same problem for X, Y and Z on a single chip. They are all going to be slightly different, this is probably only going to be a handful of analog value difference so its up to you how much you care.

  7. 6 days ago

    If you were to make a seperate device that you could use to find the biases on each axis and then move the accelerometer to your robot, should the biases remain the same, assuming the same wiring configuration?

  8. tabor473

    Oct 10 V5 Beta Tester OYES, WPI

    @caek If you were to make a seperate device that you could use to find the biases on each axis and then move the accelerometer to your robot, should the biases remain the same, assuming the same wiring configuration?

    Yes assuming ( and I had to look up some of these)

    either no gravity or the angle is exactly the same on both platforms so gravity was equivalent
    the same humidity of the room
    the same temperature
    and roughly the same point in time in the sensors life, they can slowly shift over the years

    This is why pretty much every use of these sensors finds the bias every time the robot starts...

 

or Sign Up to reply!