1 button , 2 motors

Can we program one button to control 2 motors at the same time? We need the motors to always turn the same direction at the same time and same speed.

Hi look4rainbows,

Yes, you can program a single button to control 2 motors at the same time. Are you using ROBOTC or Modkit for VEX?

Regards,

  • Art

We don’t have any programming tools. What do you recommend we can use today without buying anything?

HI,

The only built-in behavior in the Driver Control program that allows one joystick channel to control two motors are the two drive train channels. This allows either 2 or 4 motor (per per side) drivetrains.

ROBOTC has a free 10-day trial, and includes both graphical drag-and-drop and text-based programming options. There are a lot of built-in sample programs to showcase the various features.
http://www.robotc.net/download/vexrobotics/

Modkit for VEX is free for the cloud-based drag-and-drop service, and is based off of the Scratch programming language developed at MIT. You can save up to 10 programs for free in the cloud.
http://www.modkit.com/vex

Attached are screenshots of simple programs from ROBOTC Graphical and Modkit for VEX that show how to drive 2 motors off of one Controller button channel.

Regards,

  • Art

    2015-01-21 - ROBOTC Graphical 2 Motors off One Button Program.PNG.jpg

    2015-01-21 - Graphical Configuration for Motors in Modkit.PNG.jpg

Thanks! I have downloaded RobotC and I am trying to write this program, but I cannot find the drag and drop view in RobotC

When you install it gives you two separate shortcut icons, one for graphical and one for text. I remember they look slightly different. Click on the right one.

I found a file to open that had the graphical functions. But when I download to the robot it give me this error. "Failed to download user’s program file to robot controller. Error ‘Failure setting program number into robot’

Did you download the firmware to the brain?

I have downloaded the firmware to the brain and updated all the motors, brain, and controller. I plugged in another robot and it gave me the same error. At the competition, another team that had a good understanding of RobotC plugged our robot into their computer and tried to download a program. It gave them the same error. They had never seen that error.

I’ve responded to the other thread you have regarding this issue (http://www.vexiqforum.com/forum/main-category/technical-discussion/7044-failure-setting-program-number-into-robot), please try the steps outlined there at your earliest convenience and let me know what the results are (by posting in the linked thread; keeping the troubleshooting to one thread will help eliminate any confusion during the process).

Thank you in advance!