1st Gen brain only recognizes 2 motors at a time

I have the 1st gen robot kits for a club.
A couple weeks ago, one of the brains started to only recognize 2 motors plugged into it at a time. If I have motors in 1,6, and 7, for example, it only recognizes 1 and 6 as having something plugged in. If I unplug 1 or 6, it recognizes a motor is in 7. Any ideas on how to possibly fix?

Are you doing your testing with the same three motors? Might try some other motors. Do you have any similar problems with other devices such as touch sensors, distance sensors, etc? Have you tried using other ports on the brain?

Can you check the other ports on the brain and see if if the motors are recognized.

Is the brain version up to date and are the motor versions current. It may be worth force updating the motors.

I had a damaged motor that with it in port 10 it would work. With a lone motor in port 12 that motor would work, but the two of them would not work together. Through trial and error figured out the odd motor and tossed it.

Are you trying to use just the default driver code?

Good luck.

Yes, all ports are working. While in VEX OS, If i have motors in 1,6, and 7, only 1 and 6 will show a motor. If i remove motor 6, then 1 and 7 do show a motor. If i plug in to 7 and 12 and 6, then only 7 and 12 show a motor.
yes, VEX OS says brain and all motors are up to date.
I don’t think any of the motors are damaged, as we tried other groups motors on this brain and still only two will be recognized at a time

Yes we tried several other motors, from other group kits.
We have not tried to see if it will recognize sensors +motors, good idea