2.01 RobotC problems

Ok, so to start out, we recently downloaded the newest version of RobotC, 2.01. The problems started when we tried downloading code to one of our robots, we downloaded the ifi MASTER firmware, and that worked, then we downloaded the “regular” firmware, and that was fine too, then after we downloaded the code, we wanted to test autonomous, well, we previously LOST our competition switch, so we wanted to use the competition control in the 2.01 debugger. So we connected the orange downloading cable to the serial port on the back of the VexNet controller, after the VexNet linked up, we clicked “start” on the debugger, then clicked “autonomous” on the competition control, however nothing happened. “NOTE: This autonomous code WORKED at our last tournament AND with our “real” competition switch.” When we clicked on “user control” we were able to control the robot fine, but autonomous was not working, so we thought maybe the firmware had been downloaded wrong or something, so we tried to WIRELESSLY download the ifi MASTER firmware, when doing so, it got to 10% then just stopped, and gave us an error message saying it lost connection or it couldn’t download or something, so we tried directly connecting the downloading cable to the vex micro controller, we tried downloading the ifi MASTER firmware, but it said:

“Failed to enter “Master CPU” downloading mode. Check the following: 1. Verify Controller is turned on and batteries are OK. 2. Verify cable connections to Controller. 3. Veify ROBOTC ‘platform type’ setting matches actual Controller.”

We tried a few times and got the same thing, we tried switching to a different downloading cable, giving the robot fully charged batteries, and nothing was working. Also, the robot continues to twitch now whenever it is turned on, we tried downloading the “regular” firmware, it was able to download, but the robot continued to twitch while it was downloading, we tried downloading our code, and it was unable to. Right now, downloading ifi Master firmware is unsuccessful, so is downloading “Regular” firmware, and the same with downloading code.

We were able to download the new master and regular firmware to both our other robots and also run code on them, HOWEVER, autonomous code was not working using the debuggers’ competition control. These are the things I need answered:

  1. How to fix our robot before this Saturday as we have a competition that day!

  2. How to test autonomous code with the RobotC 2.01 competition control on the debugger.

Thank you for reading, and thanks in advance for your help.

**If the Master Code download is interrupted with RobotC Version 2.01, RobotC is currently unable to reprogram the unit. Download the IFI Loader (Version 1.1.1) from https://vexforum.com/wiki/index.php/Software_Downloads and install it. Download “VEXnet Master Code ver 10” and “Vex Default Firmware” and unzip them to a known location.

Have the orange programming cable plugged in to the PC and to the SERIAL port of V.5 Microcontroller.

Use the IFI Loader to download the binary file “VEX_MASTER_V10.BIN” and hex file “Vex_default_firmware.hex”. You should now be able to download using RobotC. With RobotC, download the “Download IFI Master Firmware” file “VEX_MASTER_V10.BIN” and the “Download Firmware” file “VEX VM0797.hex”. Be sure and power cycle the V.5 Microcontroller before Compiling and Downloading your user program. RobotC has been made aware of this issue.

Regarding not being able to activate Autonomous in the Competition Control Debug Window, RobotC has been made aware of this issue or you may contact them at [email protected].**