2.01 RobotC problems

(Thought I would ask everyone else if they can help me too)

Ok, so to start out, we recently downloaded the newest version of RobotC, 2.01. The problems started when we tried downloading code to one of our robots, we downloaded the ifi MASTER firmware, and that worked, then we downloaded the “regular” firmware, and that was fine too, then after we downloaded the code, we wanted to test autonomous, well, we previously LOST our competition switch, so we wanted to use the competition control in the 2.01 debugger. So we connected the orange downloading cable to the serial port on the back of the VexNet controller, after the VexNet linked up, we clicked “start” on the debugger, then clicked “autonomous” on the competition control, however nothing happened. “NOTE: This autonomous code WORKED at our last tournament AND with our “real” competition switch.” When we clicked on “user control” we were able to control the robot fine, but autonomous was not working, so we thought maybe the firmware had been downloaded wrong or something, so we tried to WIRELESSLY download the ifi MASTER firmware, when doing so, it got to 10% then just stopped, and gave us an error message saying it lost connection or it couldn’t download or something, so we tried directly connecting the downloading cable to the vex micro controller, we tried downloading the ifi MASTER firmware, but it said:

“Failed to enter “Master CPU” downloading mode. Check the following: 1. Verify Controller is turned on and batteries are OK. 2. Verify cable connections to Controller. 3. Veify ROBOTC ‘platform type’ setting matches actual Controller.”

We tried a few times and got the same thing, we tried switching to a different downloading cable, giving the robot fully charged batteries, and nothing was working. Also, the robot continues to twitch now whenever it is turned on, we tried downloading the “regular” firmware, it was able to download, but the robot continued to twitch while it was downloading, we tried downloading our code, and it was unable to. Right now, downloading ifi Master firmware is unsuccessful, so is downloading “Regular” firmware, and the same with downloading code.

We were able to download the new master and regular firmware to both our other robots and also run code on them, HOWEVER, autonomous code was not working using the debuggers’ competition control. These are the things I need answered:

  1. How to fix our robot before this Saturday as we have a competition that day!

  2. How to test autonomous code with the RobotC 2.01 competition control on the debugger.

Thank you for reading, and thanks in advance for your help.

I don’t know how to test the automous mode using RobotC as we don’t have vexnet. I can’t find it on the wiki, but look here for information to make your own test switch. Firmware should never be downloaded wirelessly. Massey University did this with one of their controlers and had to get Vex to fix it for them at the worlds.

Oh boy, so we have a competition in 3 days, and our robot has no way of being fixed, except maybe replacing the micro-controller? Do you think that would work? VEX, what do you do to fix this problem?!?!?!?!?

You can borrow someone elses controler and swap your VexNet upgrade module over until you get your old one fixed. The VexNet upgrade module will be fine. It is the controler that needs to be fixed.

Ok, I contacted our coach, so we may have 1 or 2 extra microcontrollers, we will probably have to swap it at the comp. on Saturday, but it’s all we can do for now. Thanks for helping me out here! :slight_smile:

I can certainly loan you guys a microcontroller if you need one - Just let me know in advance so that I can be sure to pack it.

I (the Team 24 Coach) have extra microcontrollers and I ordered a new test switch today. We should be fine. It would be nice to recover the corrupt microcontroller, but at some point, hopefully in the not-to-distant future, it will be obsolete anyway.