269 motor clicking

#1

I am having a problem with my vex 269 motors just clicking, and not turning. I have tried multiple motors, all do the same. I have tried several different cortexes, and it’s still the same. the program is a simple, turn motor on, wait, then turn off. I can’t figure out what the problem may be, and it’s driving me and my students crazy!!!

0 Likes

#2

Could you post the code that you are downloadimg to the cortex here?

0 Likes

#3

We are using natural language-pltw
task main()
{

startMotor(port2, 127);
wait(15);
stopMotor(leftMotor);

}

0 Likes

#4

How long is it clicking for before it stops?

0 Likes

#5

15 seconds
or until I turn the cortex off

0 Likes

#6

Sounds like the gears inside may have stripped in a spot not allowing it to turn any more. Or something is jammed inside.

I would start by opening the front and looking at the first two gears. That second gear is where they typically chip. If all clear there, open up the back side and check those gears.

While it is open, turn on the motor and see what is happening.

You may be out of luck on buying replacements though. Time to switch to 393 motors I think.

Replacement part says discontinued with no option to add to cart. You can always pilfer from other busted 269 motors.

0 Likes

#7

I opened both sides of the motor. When I manually turn, everything works wonderfully, when the motor tries to turn it, it just wiggles. :frowning: I’ve tried 10 different 269 motors, and they all do the same thing. It’s hard to believe that all of them would be bad, but stranger things have happened. Thanks for the advice.

0 Likes

#8

Are you using the same 2-3 wire motor controller? It may be that given that all these motors show the same problem. If using port 1 or 10 on the cortex it could be a blown internal motor controller (sorry if that is the case, send to Vex for repair on that one)

Plug the motor into the 9V battery directly and see if that turns the motor.

Is your battery charged?

0 Likes

#9

Battery is fully charged - I tried port 1, port 10, and a 2-3 motor controller.

0 Likes

#10

How about directly to a battery with some jumper wires?

0 Likes

#11

Have you tried changing the converter?

0 Likes

#12

Did anyone find a solution to this? I run a class that uses Vex. We’ve been having this clicking problem randomly this year with 393 motors. Motors plugged into ports 2-9 simply will not do anything, UNLESS you help them, then they’ll start turning sporadically. Changing motor controllers does nothing. Motors work fine with direct power from a 9V battery. Seems like it must be Cortex (it’s been updated, etc…)

0 Likes

#13

@sschaack, since you ruled out individual motor issues by testing them with 9v battery, it could be a problem with Cortex, code, or one of the MC29 motor controllers.

For example, if one of MC29 developed a short in its wires, PCB, or one side of its H-Bridge, then once plugged (or commanded to run in one direction) it could overload the PTC protection in the Cortex.

If PTC is overloaded and trips it may take several minutes for it to fully recover to allow normal current flow.

Can you try to disconnect all wires from the Cortex, upload test program that let you command only one motor output at a time with a joystick stick, and then try plugging one MC29 with a tested motor at a time and see if they work?

0 Likes