2nd gen controller not working

My student’s controller stopped working today and gave me the error message on the brain that reads “warning controller update radio.” When I plugged it into my Windows VexIQcode to update the firmware it reads as if it is not connected. I’m new to VexIQ and still figuring things out so any help would be much appreciated since I don’t really know what to try next.

The controller most likely does not need a firmware update unless you have updated the IQ brain recently.

Does the controller turn on and off normally ? If so, then try repairing the controller and brain.

If the controller is not turning on and off, perhaps it needs charging.

If that doesn’t work, try a full reset by removing and reinstalling the battery


The controller was fully charged and I also tried pairing the controller and the brain again but it still gave me the same message. I’ll try the full reset and see if that works. Thank you!

ok, interesting.

Had the IQ generation 2 brain received a firmware update recently ?

If the IQ brain had been on very early firmware (version 1.0.0 or 1.0.1) and updated to the latest (which is 1.0.5) then the message would be accurate. But that would mean no updates had been applied since Dec 2021 which would be unusual.

Is VEXcode updated to the latest version ? (version 2.3.1) It should detect the IQ controller when connected using a USB cable and allow updates. Perhaps try another cable or USB port on the PC.
Full instructions are here.

Does VEXcode detect the IQ brain when that is connected ?


Actually I think the 2nd gen brain did actually get a firmware update yesterday. This is the 3rd day using the 2nd gen brain and controller since my students barely received their new 2nd gen kits and had been working with the 1st gen previously.

VEXcode is updated to the latest version and does detect the IQ brain when it is connected.

That means USB cable is probably ok.
I guess try again tomorrow, you could also close the VEXcode app and try the web based version as it connects in a slightly different way,

if neither update option works, you can just dismiss the warning message on the brain (use X key) and the controller and brain should still work ok as a short term solution until you can get the controller to connect to a PC.


We just received a 2nd gen competition kit yesterday with the controller and brain. Yesterday, the students were able to run the brain with the controller. Today, the controller is continuously blinking red in the power/connection light. It will not power off completely and it is not powering on. I removed the battery to “reboot” the controllerI have an extra controller battery so tried changing it out and left it charging most of the afternoon…still the same blinking problem. I can’t guarantee that a kid didn’t do something in pairing or programming to create the problem (despite instructing them to make sure and follow the processes on the VEX IQ Electronics Library step by step. Is there a reset button on the controller? Should I update the brain firmware and connect the controller to see if that does the trick?

Thanks for any help! I’m super frustrated because it’s taken awhile to get the two kits we have (for 5 teams) and now one controller seems to be down.

I feel like a genius today. :sweat_smile: I figured it out and got the controller working. What I think probably happened is the kid who had it was trying to update and do things on his own without reading the material and didn’t close things as they were supposed, plug in as directed, or ask the coach (me) to approve the admin level to complete the firmware update for the controller. Ahhh…the life of a middle school teacher/coach. :smiley:

1 Like

What did you do to figure it out? I have the exact same problem with one of my new gen 2 remotes and nothing I’m doing is fixing it.

Never mind, finally got the firmware to update. Just needed to get off my school computer and use my personal one so the drivers could actually download (got to love district restrictions on computers :woman_facepalming:t3:).

1 Like

I think to put an end to this topic, If you are using a district owned device and downloading the firmware, and it does not work . Try using a personal device, and if that does not work make a new topic about it. I think it would be time to lock it? @Sidoti