2nd Gen IQ Brain not recognized

So I just purchased one IQ kit and am trying it out before we buy more for 4-5th grades. I had the brain plugged in and put code on it and everything seemed fine. Then I came back to the project a few days later, and now my IQ software will not recognize either the brain or the controller. I’ve tried charging batteries up, making sure V5 and VEXOS utilities are not running, different USB ports and connectors. Am I missing something? Does this happen a lot with the 2nd Gen Brains?

We have had the same problem with two of our five gen 2 brains. The other three have worked very well. It’s frustrating because their programs are gone as well when they pair the controller and brain. I think they may have pushed this out too quickly wanting to make money.

Not that I’ve experienced.
Are you programming from Mac or PC ? can you give some system details, does the brain show under ports in the device manager (if on a PC) ? Have you tried a reboot of the Mac/PC ? Have you tried a different USB cable ?

can you explain more, you mean programs they had downloaded are no longer shown in the programs screen ? Does the builtin drive program run ?

1 Like

More info - Programming from a Mac. No neither the controller nor the brain shows up in the device manager. My Mac has no USB ports so I do use an adapter. I’ve swapped that out too. The only thing left I haven’t checked is a different kind of cord. I’ve ordered a USBC to USBC to test out.

In regard to the Generation 2 brains not connecting, I am currently experiencing this with 2 of my brains in the 2 class sets I purchased.

This is happening on the chromebooks (students) and on my Windows desktop. I received this message: USB device not recognized.
The last USB device you connected to this computer malfunctioned, and Windows does not recognize it.

Brain 1: I received this message - restarted computer and brain - issue resolved.
Brain 2: Is not working on student chromebook and my Windows desktop. Tried restting to factory settings, restarting brain, changing brain, restarting chromebook and restarting desktop computer. Still no luck.
I’ll keep trying and return back here to see if others have figured out solutions.


I finally fixed it with a different cord. I bought a high-quality one from Amazon and that worked. The one from VEX burned out.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.