3 red lights on joystick

I have searched these topic several times. I have tried tons of things and can not seem to get things right. I hooked up my micro controller and it updated the firmware easy. I go to tether the joystick and brain together and nothing happens. I have 3 red lights on the controller. The brain is blinking back and forth, but for some reason they will not pair/sync up? Any suggestions? I feel like I am beating a dead horse with a stick but I promise we looked up threads on this and tried it all… Is there something I am doing wrong? I am using Easy C for programming. Updated drivers and stuff… Fresh batteries for controller and freshly charged for brain… Wont hook up with plugged together with orange usb or vex keys… When I turn on the controller all three lights are red.

Thank you,

I did it… Do not forget to hold configure down while plugging in orange cable at the same time!


You posted a question under EasyC4 about stepper motors. Not being able to answer it there, I found this post. (VEX admin or moderators can move your thread and this post to the BEST forum if they wish).

BEST no longer uses stepper motors. What you have is either a Futaba 3003 or 3004 Servo. It will only rotate 120 degrees without special software or servo modification (not allowed).

You cannot rotate 360 degrees with servos.

PM me or send me an email if you wish.

Good Luck!