3-Wire Ports Missing on Dashboard and not Responding on EXP


I have several EXP kits and they work great.

However, two of them do not having working 3-wire ports; they are still new. No bumpers, encoders, potentiometers work on A-H ports. I took a multimeter and verified the red and black wire have 5v across.
The same bumpers and encoders work just fine on other EXP brains, just not these two Brains.

I found this thread that had the same issue with the EXP 3-Wire ports.

I’ve tried force firmware updating, factory reset, browser IDE, VS Code extension but still the same result: nothing on the 3-wire sensor port.
I’ve also noticed the 3-Wire icon is missing altogether on the Sensor Dashboard on the two bad Brains:

The working EXP Brains have a 3-wire icon on the Dashboard:

Firmware: 1.0.3
VexCode IDE 2.4.5-15

I was wondering if I may have missed something or needed to update something?


contact vex support and they should be able to give you a link to reload the 3-wire firmware.


The link from Vex Support fixed the issue! The 3-wire dashboard is now working and reading input.

Thank you!