4.22 firmware malfunction

Hi,

We recently switched from using the VexNET keys to the VexNET 2.0 keys. Doing so required a firmware update for the cortex and the joystick to version 4.22, and the keys to version 1.36. Since the update, we have been unable to download our program to the robot. The wireless communication between the joystick and the cortex is normal; however, the serial link from the computer to the Vex devices is not working. We have restarted the robot and reconnected the joystick multiple times. Each time the joystick indicates that it is connected to the cortex, yet when we try to download the program, we get an error message saying, “failed to verify the serial link to vex devices.” We have also tried rewriting the firmware to the vex devices multiple times but the problem persists. Any ideas would be much appreciated.
Thanks

Dennis

Edit: My mistake, the keys are on version 1.43

As of yesterday it says the VEXNet Key 2.0 firmware is on version 1.43.

https://vexforum.com/t/vexnet-2-0-key-firmware-update/26102/1

I’d update the keys to make sure they’re at that version.

Are you using EasyC? Which version? You probably need to turn of “verify vex system” (or whatever they call it) in the download options as now your cortex version (V4.22) will not match the expected EasyC version.

Or are you on ROBOTC?

if you have robotc you also have to download the robotc firmware. I had the same issues. go to robot > download firmware > automatically Update VEX cortex. an window will pop up giving you further instructions, follow them. after you do that go to robot > download firmware > automatically Update VEXnet Joystick.

This may (not sure if it’s smart enough to do a version check) reload the master firmware, not what you want to do as released versions of ROBOTC all contain older master firmware than yesterdays V4.22.

You may need to reload the ROBOTC virtual machine firmware if when you installed the master firmware on the cortex you also downloaded the default user code (which you have to choose to turn off otherwise it will do that). Same menu, but I would use the “Manually update Firmware” and just reload the ROBOTC VM.

Thanks guys,

I’m currently using RobotC to program and I have tried all of these but nothing worked. I first updated the firmware of the cortex and the joystick with the VEXnet Firmware Upgrade program released yesterday (http://link.vex.com/downloads/VEXnetUpgrade). I also tried to use robotC’s manual download option to load the 4.22 firmware files to both the cortex and the joystick. Unfortunately although the update was successful the computer still wouldn’t talk to the joystick via the programming cord (orange USB to serial).

Dod ypu paor them after upgrading them? Silly question but needs to be asked.

yes we did tether them and both the wireless communication or corded comm between the cortex and joystick worked fine, just couldn’t download anything. We downgraded everything back to the 4.20 firmware with Vexnet 1.0 keys and everything just returned to normal. But the old keys have cut off problems so we would like to get the new 2.0 keys working with the new firmware.

We need to back up a little.

So you are using ROBOTC, which version? V3.63 or V4.08? You have the new USB programming cable, correct?

When using the VEXnet 2.0 keys, do you get green vexnet and robot leds on the joystick and cortex? If so, when you do a software inspection using ROBOTC (robot menu->Advanced tools->software inspection) does that work? Does it correctly report the master and robotc firmware versions? (only try with the VEXnet 2.0 keys, there is a bug I found today with the USB cable and VEXnet 1.0 keys).

Any chance you have PC emulator selected as the compile target?

When I know the answer to these we can go from there.

Thanks, jpearman.
Yes, the leds on the joystick and cortex are both green. Because we want to continue programming our robot using the old vexnet keys and firmware, we have been doing tests on another cortex (we tried to download a program to it earlier and got the same result as when using the robot, so we continue to use it for tests). We ran a software inspection and the results are below:

Communications Link: COM Port ‘COM12’ to VEXNET Joystick

Standard Firmware File Names:

VEXNET Joystick: .\Firmware\JOY_V4_20.BIN
VEX Cortex Master CPU Firmware: .\Firmware\CORTEX_V4_20.BIN
VEX Cortex CPU Firmware: .\Firmware\VEX_Cortex_1008.hex

VEXnet Joystick Integrity:

Firmware Version: 4.22 Newer Version (needed is 4.20)
Battery Voltage: 4.4V Poor (<6.1V)
Radio Type: WaveTrix
Calibrated: No
Joystick State: Powering Up

Cortex Master CPU Integrity: Value Status

Firmware Version: 4.22 Newer Version (needed is 4.20)
Main Battery: 7.9V Good (>6.5V)
Backup Battery: 0.0V Poor (<8.0V)
Team Name: “000VEX1” OK

Cortex User CPU Integrity: Value Status

Cortex USER CPU not responding. Firmware may need to be reloaded.

Ok, joystick battery is a little low, I assume you are powering from the programming cable. The serial port is obviously working, the radio is working and detected as WaveTrix (VEXnet 2.0). Looks like you are using ROBOTC V4.08.

So if you now try and download the ROBOTC firmware, what happens?

[ATTACH]8302[/ATTACH]
robotc_update.jpg

It worked!! You, sir, are a God. We have been struggling with this all day and it is such a relief to have it working going into worlds. All we had to do was manually update the RobotC firmware. Thank you!

Glad you are back in business. Good luck, see you in Anaheim.