ABORTED: Unable to read file system table of contents from Robot

I am unable to download anything to my robot, except for firmware. The error message is “ABORTED: Unable to read file system table of contents from Robot,” and my RobotC is running version 3.66. What’s weird is this problem only persists on a desktop, a laptop works fine(running version 3.65). I have tried it with multiple desktops with the same error.

Try doing a “software inspection” from the Robot menu and see what that shows. Make sure the ROBOTC firmware is up to date for the version of IDE you are using, you may also wish to upgrade to ROBOTC V4.56, why have you chosen to continue using V3.65?

Communications Link: USB-to-Serial Link (COM13) from Cortex to PC

Standard Firmware File Names:

VEXNET Joystick: .\Firmware\JOY_V4_25.BIN
VEX Cortex Master CPU Firmware: .\Firmware\CORTEX_V4_25.BIN
VEX Cortex CPU Firmware: .\Firmware\VEX_Cortex_0968.hex

VEXnet Joystick Integrity:

No joystick connection. Direct USB-to-Serial connection to PC.
Joystick State: No joystick. USB-to-Serial

Cortex Master CPU Integrity: Value Status

Firmware Version: 4.25 Up to Date
Main Battery: 0.0V Poor (<5.6V)
Backup Battery: 0.0V Poor (<8.0V)
Team Name: “00ROBOTC” Default. Not Assigned

Cortex User CPU Integrity: Value Status

Cortex USER CPU not responding. Firmware may need to be reloaded.

Ok, this implies you have not installed the ROBOTC firmware in the cortex.

The best way to do that is manually selecting the file as shown in this screen shot.