About the VEXcode V5 Text Tech Support category

Have a bug in your code? Ask any VEXcode-related questions here!

We have been using VCS & tried to import our competition template to VEXcode. Import went well but when we clicked build, we can’t seem to find it on the V5 brain. The home screen has the joystick icon, settings, VCS buttons, program folder button … but we can’t seem to find a VEXcode button for the file that was downloaded. Did we miss a step? Thank you.

That’s ok we got it working. For some reason, we were not getting the download button, just the build button. Followed the instructions for VEXCode which shows the build button, not the download button. I don’t know if the VCS Update 1.0.6 made the difference but later in the day when we showed it to our mentor, we disconnected the download cable & restarted (which is what we had done 3 times earlier) but all of a sudden the build button now appeared as the download button. This enabled us to download onto the V5 brain. Was it just because we had downloaded update 1.0.6 or was there some other reason the download button did not appear earlier?

Capture
When I open VEXCode, this blank screen pops up. It doesn’t allow me to create any new projects, or open existing projects. I have a windows 10 computer, so it should be compatible. It looks like the text-editor part isn’t working at all. Most of the buttons pull up dialogs, except the check for updates button. Any idea what could cause this error?

What is the current or planned support for communicating with custom electronics. As a vexu programmer I am interested if we will be able to interface to arduinos and such with VEXcode via the smart ports.

@jokai You’ll see the download button when you plug in your V5 Brain.And make sure that your V5 Brain is connected to the controller.

Yes, my team would be very interested too.

Did you install all latest video drivers? We had similar problem and driver update fixed it.

So far I love using VEXcode. I live in Visual Studio so this was a nice change.
I’ve encountered a few issues with v0.9.
I installed VEXcode on freshly imaged school laptops. VEXcode would not show connected to the V5 at all. It worked fine on my personal laptop, which had RobotC and VCS already. The install must not include the USB drivers? I installed the stand-alone firmware update utility and that took care of the USB driver issue.
The school laptops are very secure. That presents a problem with student accounts for compiling that didn’t exist with RobotC or VCS. They just get an error: The command prompt has been disabled by your administrator. It works fine with my account because I have temporary admin rights to allow me to install software. I’m going to try to get this adjusted, but it would be nice if this wasn’t needed.

I open a program setup two motors and get this:
What am I doing wrong?

image

I was told that, that version doesn’t work yet and you have to use the blocks, if i am wrong ignore me but thats all i have heard.