Another VEXNet 2.0 Q...

Like many others, we are having 2.0 trouble, but I can’t find any info that matches our problem.
I have 8 teams at my high school and last year we traded in all our old VEX keys for the new 2.0s. This year, the first team to finish and program a chassis grabbed two 2.0 keys, updated the firmware, and everything worked perfect. Next group, no luck. Long story short, we found out we have two different keys (see attached image). One says 4285AG on the back, the other is blank. All of the blank keys work, but the 4285AG keys do not (and they won’t work if you do one of each). We can even have a robot running around on a blank key, swap for a 4285AG and it will stop working. Swap it back, and it works again.
We also got some new kits this year, and as new as I can figure, the working keys came from those kits and the 4285AGs are the trade-ins. But thats just a guess since I threw them all in a box together.

About the “Not working”: When you put a 4285AG in, the Joystick light will turn solid green and the Robot light will slowly blink yellow. After about 3 yellow blinks, all the lights flash red and the Robot blinks yellow ~4 times really fast. Then the whole thing repeats over and over…

Thanks for any help you can provide!

Hello leejones15,

Thanks for taking the time to visit our forum.
The “4285AG” number is simply a factory date code, and has nothing to do with the performance of the unit. The problems you are having are most likely caused by a combination of different firmwares in your systems.
A VEXnet system will only work if it contains matching firmware in the VEXnet Keys, Joystick & Microcontroller.

What I recommend is to update all of your systems using the firmware we have listed in our website. This means, you will have to install in your PC the following firmware update utilities:

VEXnet Firmware Upgrade Utility 4.1.5
VEXnet Key 2.0 Firmware Upgrade Utility V 3.0

Once they are installed in your PC, let me know and I can go in further details.


Firmware.pdf (308 KB)

Hey Eli,
Thanks for the info. We did that (followed the steps in the zip file) and it says the firmware for the “4285AG” is up-to-date, but it still doesn’t work. When we plugged in a blank one, it said it wasn’t up-to-date, updated it, and now they aren’t working either…
Same light blinking pattern, only now it is happening with the blank ones we updated, too.


Please update all of your VEXnet Keys 2.0 to the same version (1.46).
Once complete, you will need to update your Microcontroller & Joystick using the VEXnet Firmware Upgrade Utility 4.1.5.

Once your complete system is updated, it will work :slight_smile:
Let me know your results.


Thanks, Eli. Got all that done and it works with the few we tested (real test will come tomorrow in class when everyone is hear). Does the firmware need to be installed on all the computer we use for RobotC? We just installed the firmware on two computers, then systematically plugged in each controller, cortex, and key to update them. If we pass those out to teams as is, should we be good to go?
I’m sure we’ll find out first-hand tomorrow, but just checking in case there is something I can get ready before everyone arrives.


Glad I was not able to help.
The VEXnet Upgrade Utility & the 2.0 Firmware Upgrade Utility do not have to be installed in every PC in your classroom; however, it can make things easier for you if its installed in all of your computers.