Answered: Cannot download EasyC program to controller

I am getting the following message whenever I try to download EasyC programs to the micro-controller: “To enable download, make sure that power is on and the serial cable is connected.”
It worked fine for several days, but now I keep getting this message.

The power on the controller is on, the battery is charged and connected, the cable is attached to the computer. The LEDs on the Vex microcontroller are:

BATT POWER: rapidly blinking green
PGRM STAUS: steady green
Rx 1 STATUS: off
Rx 2 STATUS: off
The amber light above the 4 LED’s: off (it used to be always on, I think).

When I turn the robot off and on, nothing changes. I have tried rebooting the computer. I have also tried downloading the default HEX code and the master code, but they can’t download – the same message appears.

Please help.

Answer: Try using the IFI Loader - See post “Programming light is always on” under Programming FAQs

I have downloaded the IFI Loader, installed, started it, connected the robot, turned it on, checked the cables, and then pressed Options | Controller Verification in the IFI Loader. It said “No Controller Found…” at the bottom.

The computer just doesn’t “see” the robot. Could the cable be faulty? Could the controller be broken?

Thanks

With everything connected and powered “On”, open the Terminal Window on the IFI Loader. Now power cycle the Vex Controller several times, what do you see in the Terminal Window?

Ricky,

Nothing appears in the IFI Loader’s Terminal window when I power cycle the controller.

Thanks

Ok, you are not getting communication in either direction. Is the IFI Loader using the correct COM Port, also see https://vexforum.com/t/programming-problems/13283/1&highlight=Port

More things to try:

  1. If you have a different computer, try it.
  2. If your computer has a Serial Port use that and a DB9 Male-Female cable instead of the USB to Serial Adapter.
  3. Try a different Programming Module if you have it.
  4. Try a different Vex Controller if you have access to one.

The problem can be anywhere in the loop at this point: Computer Port, USB to Serial Adapter, Programming Module, RJ14 6-pin cable, or the Vex Controller. Try eliminating one at a time to find where the problem is.

Also see, https://vexforum.com/t/advanced-programming-ideas-part-9/13914/1&highlight=Port