Answered: Channels 2 & 4 reading -254 when centered

Running RobotC Rev 2.16Beta.
Using the new Joysticks and a Cortex controller, channels 2 & 4 read -254 when centered, -127 when pushed to the negative limit, and -368 when pushed to the positive limit.
We have tried downloading the default code as suggested in an earlier thread.
Do you have any other suggestions?

Did the Cortex / Joystick ever work? Do you have other units that are working?

I have a second new joystick that gives the same result and I think that the kids tried an old joystick with VEXNet installed and got the same results.
We have another Cortex that will not download anything. I believe that it always says autobaud error. I am going to attack that problem once I get the basics on this unit working.

**I would try using our VEXnet Firmware Upgrade Utility on all your Cortexs and Joysticks. **

I only have one Joystick and one Cortex at home.

  1. I updated both the Joystick and Cortex with the VEXnet Firmware Update Utility

  2. I downloaded the firmware (VEX-Cortex_810.hex).

  3. I calibrated the Joystick.

  4. I compiled and downloaded the VEXNET Controller Test sample program.

  5. The results are unchanged.

  6. The center value is -254. As the Channel 2 stick is pushed forward, the value becomes more positive rather than more negative. The range (127) is correct. The center point and incremental change are wrong. The complement is true when the Channel 2 stick is pulled back. The value gets more negative rather than more positive. Channel 4 exhibits the same problem.

  7. We have class tomorrow. I’ll have a student repeat the update and test on our other VEXnet equipment (old style and new) and report the results.

  8. Our workaround is the add 254 to the Joystick value and multiply by -1.

Randy Wood

I just noticed the Trouble Shooting menu and tried the VEX Net Controller test.
The X1/X2 and Y1/Y2 values are consistent. All other displays appear to be correct except the accelerometer Z axis is always reporting zero.

I also downloaded the default firmware, disconnected the programming cable, cycled power on the controller and attempted to see if Channel 2 would drive the associated motor. I couldn’t get any response from the robot, so I assume that I need to connect the competition switch. I’ll try that tomorrow morning.

I just checked the RobotC forum and found that this appears to be a know problem in RobotC.
Thanks for helping and I’m sorry for wasting your time.

Glad you found were the issue is.

Tried to Send you a PM, but it is disabled?

Thanks for the email. I’ll try easyC this weekend.
I don’t know what the problem is with messages. In my UserCP, it says that I an allowed 0 messages. I didn’t see any place to enable them. Maybe there is a minimum number of posts before PMs are allowed?