Answered: Connection issues

Per my last post,a few monthes ago, I did send in the vexnet keys and microcontroller. I received either the same pieces back or replacements-I’m not sure which as their was no invoice etc in the return box. So I have set things up but still have problems.
Using easyC ver 4, and vex microcontroller and vexnet key system.
On powering up the joystick and microcontroller the following LED pattern appears, on Joystick: js-solid green, robot slow blinking green, vexnet rapid blinking green. On controller: robot slow blinking green, vexnet rapid blinking green game- blank.
When I try to download a program from easyC, the program will build and compile ok but won’t run and the error message: communication between the joystick and microcontroller is a problem-update master code. I have updated the master code with report on both the js and mc being BootLoad 6, Master 2.6, ID 10668.
I think the LED pattern indicates the microcontroller is downloading master code, what do think and suggest?

First, which version of the Vexnet Upgrade Utility are you using to download master code. You should be using version 1.2.3 found here:

VEXnet Firmware Upgrade Utility v1.2.3a (zip, 04-10-11)

After downloading Master and Default code from the Upgrade Utility, try to test functionality.

Second, about how slow is the Robot light blinking?

The IFI/Intelitek Loader I was using was ver 1.1.7 ;
So I updated the loader to ver 1.2.3 and then per directions hit config sys button then connected USB, then downloaded MasterCode, and repeated this on the joystick. It reported vexnet code was up to date after downloading on both.
I then tried to download Default Code from the easyC ver4, software program, connecting the joystick to the computer by the RS cable,but the same message displayed:
IFI/Intelitek Loader
Please check the communication of the joystick to the micrcontroller and verify it is on…

So I connected the computer to the joystick with the USB cable, tried to download Default Code and the error message: Cannot read controller configuration. The same message occured when connecting to the microcontroller.

With the Vexnet Keys in place and both JS and Microcontroller turned on, the LED patterns are now:
Microcontroller: Robot-1 blink/sec green, Vexnet and Game-rapid yellow blink.
Joystick: Joystick-solid green, Robot-no light, Vexnet-1 blink/sec red.
Any suggestions?

**First, let’s get some more information:

What was displayed in the VEXnet Utility Window at the end of updating the Joystick and CORTEX?

Can you control the CORTEX without issue while being Tether to the Joystick with the USB A-A Cable?

Are you downloading the Default Code using the USB A-A Cable only – a direct connection between the CORTEX and PC with the USB A-A Cable?**

I can’t recall verbatim the message after downloading the master code, but I had printed out the instructions that downloaded with the Loader update and was following them. After the master code downloaded to both the microcontroller and the joystick I recall the message did not exactly match any of the possibilities given in the instructions, but the last phrase was the “Vexnet is up to date”.

When the js and controller are tethered together with the USB cable the robot does not move in response to the joystick, but I don’t believe a program is in the microcontroller as downloading a program is the issue.

As in my prior post, I tried to download the Default Code first with the USB to serial/programming module connected to the joystick. I got the error message as stated in last post. Same thing happened trying to download with the USB cable from the computer to the joystick and then to the controller.
Again tonight the same LED patterns are present when turning on the controller and joystick with vexnet keys in place:
Joystick: js-solid green,robot 1blink/s green, vexnet rapid blinking green
Controller: robot-1 blink/s green,vexnet-rapid blinking green,game-nolight.

Tonight when I tried to download Default Code from easyC program, using the USB cable to connect computer to joystick, then to controller, the same message displayed “Do not recognize controller configuration”.
So, I tried again to download Default code and got the message "EasyC has detected an incorrect version of mastercode on you Cortex microcontroller. Following the help button I opened Vexnet Upgrade Utility ver 1.2.3 and connected via USB cable, computer to microcontroller, hit Search, it says Vexnet is up to date.No action required. I hit Boot Load and downloaded Master Code, and got message: Default download complete, Vexnet is up to date. Data from Device: Boot Load 6, Master 2.8, ID 10668, Default Code on.
I then connected, via USB cable, the computer and joystick and repeated. The Master Code downloaded, message states: Vexnet is up to date No action required. Data from Device: BootLoad 6, Master 2.41,ID 10668. Then I went back to easyC software to download Default Code. The error message came up:Cannot download in Boot mode.
Now the LED patterns on the joystick and microcontroller - with Vexnet keys in and both turned on are:
Joystick: js-solid green, robot - no light, vexnet-rapid blinking green.
Microcontroller: robot-1 blink/sec green, vexnet- rapid blinking green, game- no light.

What happens when you Tether from the Joystick to the CORTEX with a battery on both and both are turned ON. Can you drive motors per Default Code? If not, I suggest you contact our support team for a RMA Number to return the system for repair.