Answered: Cortex-Controller Disconnect

We are having the same problem that Dave stated as he was helping our team at the competition this past weekend.

When we were using the cortex handset in wireless mode, in 10 to 15 seconds the cortex would disconnect. The vexnet light would turn red. One thing we did was we changed and charged the batteries on the controller and the cortex. We had also changed and the hex keys and that did not work. (We tried 2 different pairs of keys.) Then we checked all the firmware. We also changed the laptop and restarted the computer. We reproduced the problem with a new joystick and cortex. When using the A to A cable to the handset there were no issues. We uninstalled the easy c program and reinstalled it. After updating the firmware and bootload we repaired the joystick and cortex. When pairing we got a flashing green light for the robot button and a solid green light on the vexnet. After switching it to the keys it seemed to work. It worked for a few minutes. Then we turned the cortex off and after restarting the cortex it would not work again. This time we got a yellow vexnet light. It appears that the cortex just keeps restarting. Help is needed for this problem because we have a competition this Saturday and cannot figure out how to program our robot.

atruex,

I would like to get back your VEXnet keys for testing.
Please email support@VEXrobotics.com for further instructions.

-Eli