Answered: Cortex Lights and Communication

[FONT=“Times New Roman”][/FONT]

Recently we’ve run into a problem with blinking lights. I downloaded a program into cortex and all of a sudden, the robot and game lights started blinking green while the VEXnet light was not on at all. We cycled the power and disconnected the brain from everything except the battery, but we still ran into the same problem. When we attempted to connected the joystick to the micro-controller with an A-A cable, all three lights (Robot, Joystick, and Vexnet) lights blinked green, but it wouldn’t run and did not receive any commands from the joystick. We re-downloaded all three firmwares, (Master CPU, Joystick & ROBOTC) and re-calibrated the joystick and the VEXnet, but the lights didn’t change until we downloaded the ROBOTC firmware. When this firmware was downloaded, the VEXnet and game lights started blinking green, and the robot light turned off. At this point, we assumed that the memory was cleared and that there was no longer a running program on the brain, so paired the joystick and micro-controller. We found that they were communicating, but the robot was running a very weird program, one which we’ve never created. So we downloaded our regular program, and it went straight back to the blinking green VEXnet and game lights-- our original problem.

We have tried to address this problem several times, with and without pairing in between firmware downloads, but we always got the same result. Once after downloading all three firmwares again, ROBOTC told us to cycle power before downloading our program. Our robot was being powered by the A-A cable, so we unplugged it, and plugged it back in; when we did this the blinking lights problem started again. So we tried to download the firmwares once more, but this time, before trying another program download, we unplugged the A-A that was powering the robot, and the unoriginal lights that occured after the downloading of the ROBOTC firmware (with the VEXnet and game lights on, with the robot light off) resumed. After a series of testing, we concluded that the original problem lights (with the robot and game lights blinking green and the VEXnet light off) only occurred after we got the message from ROBOTC to cycle power.

We tried all methods of downloading, through the regular programing cable and the A-A, and we also tried different computers, but the results were the same. This problem has happened systematically to three different brains (of three different robots) over the course of less than 1 day.

The problem started happening when we downloaded an unedited competition template from ROBOTC. Finally, when we didn’t know what else to resort to, we downloaded programs that have been working on our robots for two competitions in a row, and we still got the same result. In our last few attempts, we tried downloading an empty program into the brain; that didn’t do anything either.

Updated your ROBOTC Software which will also update your VEXnet Upgrade Tool. Now try downloading Master Code, ROBOTC Firmware and then Default Code to the CORTEX. Be sure to update both the Joystick and CORTEX and then Tether with a USB A-A cable.