Answered: Cortex Update Error

I’m using EasyC 4. Whenever I try to load a program on the Cortex, I get an error saying that the Cortex needs to be updated from Master code 2.6 to 2.7. However, when I try to update it using the IFI update utility, it says it’s up to date at 2.6. Is there a new updater I need to download?

You need to update your easyC software – click on Check for Updates under the Help Tab inside the easyC software. Then follow their instruction for updating Master Code.

EasyC is up to date according to the website. It is currently version EasyC itself needs the Cortex master code to be updated to 2.7, but the firmware update utility recognizes master code 2.6 as up to date.
We are using the trial version while we are sorting out how to purchase it. Could that be the source of the problem?

There is a issue with IFI Vexnet Update Utility that shows 2.6 as upto date. Just click search->bootload->download in the IFI VexNet Update Utility and overwrite the mastercode on the robot and you will be good to go. We will be releasing an update shortly, we are in final testing for the next release.

Thanks. I was messing around yesterday and managed to update both the Cortex and vexnet joysticks to the new firmware versions. Code downloads beautifully now. Sadly, now I have a new problem that I think you guys could help me with.
After I download code to the Cortex, none of the remote control functions work. The vexnet system is paired with green lights on both Robot and Vexnet, but none of the joystick functions work with the Cortex. I suspected my code, but none of the example programs work, either. I also wondered if the motors or ports are faulty, but if I add a “motor 2 to 256” or similar command, the motors work.

I would try updating the firmware again.

I tried updating and also using another computer. With another computer autonomous commands work, but not any remote control functions. What’s even more puzzling is that the vex joysticks worked perfectly with the default code the Cortex came with. Do you have any other suggestions? I’m going to try a variety of radio control commands to see if any of them work.

Never mind, I figured out the problem. This is my first time using easyC, and I was unfamiliar with the syntax. I assumed that user code was automatically run in an infinite loop, instead of just once. Thanks for your help, it works now.

Glad you got it working…