Answered: failed to get system info

Downloading code from V4 to the cortex I get get the following error.
failed to get system info (trying to get info with the cable unplugged) **

I saw an answer in this forum from a year ago with a similar problem, but mine is a bit different.

I have the latest version of EasyC V4, i have the correct master code on the controllers (3.23), and the drivers for both the usb and serial connections. I am able to update the master code on controllers and joysticks, and i can program through the usb cable directly to the controller, but when i try to use the usb to serial connected to the joystick, the so called “advanced programming kit” (and the cable has never been used before i tried) i get the error mentioned above.

Also it is probably unrelated (though who really knows) but for some reason Arcade mode doesn’t work on channels 1/2 only 3/4 even though i can use tank mode with channels 2/3. I figure that has to be a bug in the software not a problem with my joystick. I can post a separate question about this but for now figure i should keep it here in case the problems are actually related.


What kind of Hardware Programming Cable do you have, pre-June or post-June?
See webpage for more details:


I wasn’t aware there was a new cable, but I’m definitly using the old one. Can you still use the old one? is there a driver for it?

it is pre june, but the pre june model driver does not work.


While the cable is connected to your PC, please take a screenshot of your Windows Device Manager.
It should look like the PDF attached.

Doc1.pdf (118 KB)

Sorry I’ve taken so long on this. I abandoned the old programming cable and bought the new one, but the problem is still the same, The computer appears to recognize the device, and even installed the driver when we first plugged it in, but the Program doesn’t see it. I’ve attached the view that was asked for.

Keep in mind that we have up to date code and the new programming cable.
Device Manager.jpg

So i got to checking around and found out that the automatic setting in EasyC isn’t finding the right port, I switched to manual and it works like a charm now.