Answered: Lost connection between Microcontroller and Joystick

We are having some difficulties with our robots and microcontroller. We are having problems keeping the connection between the microcontroller and joystick. It continually loses connection. The lights on the microcontroller and joystick indicate that it is searching for mate and loss USB link. We have tried every trouble shooting options and even updated it. We are wondering if there is another way to fix this ongoing problem. Only two of the three classroom kits we have do it.

clevelandrobotics,

Lets isolate the problem.
Take the VEXnet keys from the functional unit and try them on the other robots.
See if you are able to establish and maintain a solid link.
Thanks.

-Eli

We have charted for two days and we are still losing connection in two of the three USB sets. After charting, one USB works in every robot and has had no problem.These two sets lose connection in every robot after two-three minutes after driving. After a while one of the sets of USB wouldn’t even connect to the robot it came with. We are wondering what we could still possibly do? We are wondering possibly if running all three at the same time would make any difference or cause more problems? Thanks!

clevelandrobotics,

Running multiple VEXnet Keys in the same room will not cause interference.
Please email support@VEXrobotics.com and request a RMA for the return of the keys.
Once received we will test them and let you know the results.
Thanks.

-Eli