Answered: Master Erase Failure

I am unable to download any code my PIC microcontroler. i have searched the forum for all possable solution. when i try to go back to “square one”. Robotc gives me an error “unable to erase”. i have also tried the IFI loader from which i am able to verify the controller. the terminal window of the IFI loader spits out garbage when the microcontroller is connected (an infinate stream of “w”, “/” ,"-" and “>” ) when i try to download the latest master code the status bar says “establishing port connection” and fails with “Unknow device ID (0)” this problem seems to be the same problem described in a post 4 years ago ( but no ultimate solution was suggested. I am sure the IFI loader is on the correct com port.

Can you download Master Code to a different PIC Microcontroller? Also, what is the state of the LEDs on the Microcontroller?

The lights are the same as in the related post. Solid programing light and quick flashing battery light. i tried reprogramming this microcontroller from a different computer that i know works on other microcontrollers but i do not have another microcontroller to test with.

With a PRGM LED On, you need to download Master Code to correct this issue. If you can not download Master Code to the Microcontroller with a “good” programming system, you will need to call our Tech Support Line (903-454-0802) and get a RMA Number to return the unit for re-programming/repair.