Answered: Motors won't follow joystick with Y-cable.

Hello Everyone,

My partner team is having an issue and quite a few of us put our heads together in an attempt to find the solution.

The is with the motor control. 4 motors on the drive are connected via a Y-cable, 2 motors in each Y-cable. When the motors are connected into individual ports, say port 2 and port 3, the motors run fine. The joystick control works, and everything’s nice and dandy.

When we connect the motors with a Y-cable, one setup of the y-cables makes the motors do nothing, and then when we flip the PMW connections, the wheels take off and they do not stop, and joystick control does not seem to work.

We have tried 3 different y cables, we have tried using a different laptop for code (although I’m not sure how that would help), and we’ve tried simplifying our code to see if somehow -127 and 127 are being added to the port value.

Unfortunately nothing above has been fruitful.

Any insight would be appreciated.

**Do all 4 motors work correctly when connected to port say 2? Connect only 1 motor via the Y Cable, via port 2. Now connect 2 motors on the Y Cable. Also try different ports…

As a work-around, you could eliminate the Y Cable and change the program so all 4 motor work off individual ports.**