Answered: Power Expander Issues

We recently purchased a power expander, and it has been working fine. But today, it is not working. The LED blinks like it’s supposed to when we plug in a (charged) battery, but after we turn on the bot, the LED turns on green, and immediately changes to red, and our motors that are powered with the expander do not work.

What kind of motors are you using?
Also, are you using the Status port on the Power Expander?


We were powering 2 2-wire 269s and 2 393s with the power expander, and no, we are not using the status port.

The cause of the problem might be that, yesterday, one of our motors had a short circuit, which caused its extension to rapidly heat up, and also making some other motors on the robot stop working. However, it was not one of the motors that was plugged into the power expander, and after it was removed and replaced, the whole robot had no problems.

When the LED on the Power Expander turns red, is it a solid, slow blinking, or fast blinking pattern?


When we turn on the robot, with everything plugged in, the LED on the power expander turns on green, and then immediately changes to a solid red.

We tried using a different power expander, and it works fine, so something’s wrong with ours.

A solid red LED indicates a low battery:

Are you using the same battery on both Power Expanders?


Yes, we used the same battery for both power expanders. The battery had a voltage of 8.66V. Also, with the robot on, it showed that the battery plugged into the brain was green, so we switched that battery with the power expander battery, with the same result (red LED).

Please contact VEX technical support directly: