Answered: Power expander status port breaker trip

Hello, i am having this problem on my power expander when i try to connect to the status port. i read the documentation that said to connect a PWM cable from that port to the cortex. when i plug the cable in, it trips the breaker on the power expander. I watched the reading and it gave me a voltage of ~5.4. The indicator light on the power expander blinked red and the motors ceased to function. The cortex seemed to be unaffected. On a hunch, i disconnected the +5 (red) wire, but got the same result. Any ideas? Anyone else have similar problems?

No, you do not have to change your code – the same PWM Signal that is used to drive a Motor should be sent to the Power Expander. You should check your wiring; you can connect the Inputs and Outputs incorrectly if you are not using Keyed connectors. Please refer to the WIKI documentation.

Sorry if i did not provide enough information. I am trying to measure the battery voltade on the power expander. Whe i would connect the status port to an analog input, which would trip it. The power expander indicated a fast red blink, indicating a low battery condition. I think that this is after a breaker trip and just reading the cortex voltage. I was reading the voltage and displaying it on the lcd screen. i tried reversing the cable, and i got 0.0 on the voltage. The other direction showed 5.4 volts.

There is a voltage divider inside the Power Expander STATUS port and inside the CORTEX Analog Input ports. Do a read of the analog port. Using the 10-bit A/D of the CORTEX, divide the number you get by 45.6 to get the battery voltage. So an A/D count of 344 is a Power Expander battery charged to about 7.5 volts.

The Wiki will be updated to reflect a different divide by number for the CORTEX than for the V.5 Microcontroller.

Thank you for clarifying the difference between the readouts on PIC and CORTEX controllers. this would somewhat explain my problem. By the change in A/D readouts, i would have had a voltage of ~8.3, which is correct.
But what i really want to know is why the expander flashes red as if it was tripped when connected through the status port. Is this normal? has anyone used the power expander status port before?

The processor inside the Power Expander monitors the Status Port output to determine post-circuit breaker battery voltage. A “0” digital output from the CORTEX or V.5 Microcontroller can force this Status line low. A reversed extension cable into the Status Port can force this Status line low. Either condition tells the Power Expander it has a simulated circuit breaker trip. So it displays the blinking red pattern.

If you are doing neither of these, please post pictures of your wiring so we may determine if something is cabled incorrectly.

I made an error in my first post; instead of the motors on the power expander NOT working, they work fine.

I now get accurate voltage readings, thanks to corey-ifi. The voltage is now >7.2.

Everything works fine, except for the light. The red blinking light is only a superficial problem now, but i did want to get to the bottom of it. Its kinda distracting; making you verify that it is working. It also prevents spot-checking the operating condition of the expander.

I will try and get a picture of it Monday afternoon.

Exactly when does the LED turn RED? What happens you only connect Power to the Expander – no other connections? Now add only the status cable? Now add the Input PWM Cables and activate the PMW signals (full forward and full reverse)? Now add the PWM Motor Cables to the Output Motor Ports?

The several situations that i have observed:

yes power; no status; no in; no out; no pwm - green
yes power; no status; yes in; no out; no pwm - green
yes power; no status; yes in; no out; yes pwm - green
yes power; no status; no in; yes out; no pwm - green
yes power; no status; yes in; yes out; no pwm - green
yes power; no status; yes in; yes out; yes pwm - green (regular config)
yes power; yes status; yes in; yes out; no pwm - red
yes power; yes status; yes in; yes out; yes pwm - red (but works)

That is all that i have tested, as i will not be able to touch the robot until Monday.

When the expander is off and everything else is on, its off.
When i plug the battery in, it waits ~ 1/4 second and then turns red.
If the expander is on with everything but the status port connected, its fine.
When i plug in the status port, the light goes red immediately.

Since you can read battery voltage, I am assuming you have the Status Cable connect to an Analog Input wired correctly – incorrect wiring can cause your failure. To verify, use different batteries that have different voltage due to different voltage charge levels – you should be able to read the different batteries voltages. If you can, I suggest you call our Tech Support to get a RMA Number for the return of the product.