Answered: Power

When turning the Cortex unit on, the LEDs give pattern of:
robot-no light
vexnet-blinking red (slow)
game-no light

I’ve put 2 different sets of new batteries in the Cortex unit with same result, and battery cable is securely plugged into Cortex. Result is the same if turned on with Vexnet Key in place or not, and if Joystick is on, it’s LED pattern is:
joystick-solid green
robot-no light
vexnet-rapid blinking yellow

Earlier today I was driving the 'bot around with use of the Joystick when the batteries in the joystick “died”, if that might make a difference.

What do you think?

I thought the Cortex might have to be reset because it was running then the joystick’s batteries “died”, so I did a Config-Sys manuver-plugging the USB cable into the controller while the config button was depressed. The LEDs all turned green. Then I downloaded Master Code with the Utility program-which took about 30 minutes to complete. But still no improvement, when I turn on the Cortex the robot light is dark, the vexnet light is blinking green, and the game light is blinking yellow. With the VexNet keys in place the LEDs show:
(on Joystick): joystick-solid green,robot-no light, vexnet-blinking yellow. Thanks in advance for any assistance.

[FONT=“Georgia”]Have you tired to directly tether the COREX to the Joystick yet?[/FONT]

When I tethered the two together as suggested, with the cortex turned off the LED patterns are:
joystick: joystick-solid green, robot-slow blinking green, vexnet-solid green.
cortex: robot-slow blinking red, vexnet-solid green, game-no light.

When they are tethered and then the cortex is turned on the LED pattern is the same, but the motors run.

After the above, when both joystick and cortex are on (untethered) the LED pattern is:
joystick: joystick-solid green for a few seconds then blank, robot-no light, vexnet-red double blink
cortex: robot-no light, vexnet-red double blink, game-no light.

Give you any insight?

**Try different VEXnet Keys if you have them. Also, run the Upgrade Utility Tool on both units again after updating you software - What is the ID on both units when you get the “no update required” message while running the Tool. **

I don’t have alternate Vexnet keys to try.
I ran the Vexnet Upgrade Utility on both the joystick and the Cortex units. It reports Vexnet is up to date No action required. ID is 10668 for both units.

My guess is you have a failed Key(s). You should call our tech support (093-453-0802) for an RMA Number if the Keys are still under warranty.

Now when I power up the Cortex, the LED pattern is:
robot -no light, vexnet slow double red blink, game-no light.
I checked batteries with multimeter-good there.
When joystick is turned on with Vexnet keys in LED pattern on joystick is:
joystick-solid green, robot-no light, vexnet-rapid blinking yellow, the cortex LED pattern doesn’t change.
I don’t see how changing the vexnet keys will affect the robot power LED, and wonder if it is a Cortex problem.
Thanks for your assistance, hope you had a good time in Omaha, my home-town.

What you are seeing is an Error Code for “NO VEXnet Key detected”. During an Error Code, the normal blink patterns are disabled so only the Error Code is displayed. You should call our tech support (093-453-0802) for an RMA Number if the Key is still under warranty. Please refer to the User Guide for help on what the blink patterns indicate. **