Answered: Problems using VexNet wifi keys

I am a programmer for 599 team C. As it seems to be the pattern, we are having more cortex issues. Two of our teams have finished code and were in the beginning stages of testing code. We had no issues downloading and running code while tethered to the robot via usb. We have a field and were hoping to get some practice on the field, playing the game. We ensured that the Joystick was paired with the Cortex via usb, then we unplugged the usb cables and switched to the VexNet USB wireless keys. As of now, both of our teams have lost the ability to pair the Cortex with the Joystick and the cortex is no longer recognized by our laptops. We tried using the Vexnet firmware utility upgrade tool to reload firmware which worked to upgrade our cotex’s to the newest firmware, the same with our joystick. However, neither the Cortex or Joystick is recognized outside of the firmware upgrade utility and we are unable to download RobotC firmware so that we can download our code. Please help us if it is possible. ’


I’m sorry to hear that you are having difficulties downloading into your Cortex.
The first issue that you may have is different Master Code versions between ROBOTC and the VEXnet Firmware Upgrade Utility.

Try this:

  1. Open ROBOTC
  2. Click on the “Help” tab
  3. Click on the “Check for Updates” option

Are you running the most current version?
If not, please update.


I can’t get to try this out until Monday, but I think this might fix the solution, I know we are definitely running RobotC 3.03, so I will definitely update as soon as I get the chance. Thank you very much.

Alright keep me updated.


We updated RobotC to the current version and the Vexnet keys seemed to work. However, as we found out during the Patriots/SMI Gateway challenge, it was actually a couple of our Vexnet Wifi keys that were broken. They must have been shuffled when we updated, but thank you anyway!

Glad your system is working now.
Thanks for the update.