Answered: Programming Status Light Doesn't Turn On

I just bought a VEX kit second hand, and the programming status light refuses to do anything. The programming button on the cable doesn’t help. However, when I try to download a program through the programming cable, the microcontroller starts beeping, then it stops when I stop trying to download. However, it always runs the same program that it started with (previous owner loaded it). I am using the Linux version of IFI Loader, “picloader”, which has worked fine for numerous others, and IFI Loader won’t even install on my family’s Windows computer due to some obsolete files or something, so I can’t tell if good ol’ proprietary IFI Loader will do the trick. However, there should be something happening to the programming status light regardless. Any thoughts? No problems were reported from the previous owner.

Update: Managed to find a different version of IFI Loader that works, and I have a new symptom. When I verify the controller through IFI, I hear a click from the microcontroller.

Not sure what the clicking you hear is. I would try reprogramming the Master Code (.bin file) and then the Default Code (.hex) using the IFI Loader.

That’s not the problem. The light doesn’t come on, meaning the controller or the cable is not going into download mode. I’ve tried several times to download multiple versions of the default code, and it hasn’t yet worked. I know the beeping during download on Linux I figured out is coming from the motors ticking a little bit and I’ve narrowed the clicking down to the computer. I’ve also tried downloading the firmware (connected the OI to the microcontroller just like it said), and … nothing. IFI loader verifies that the controller is there whether or not it’s actually connected, but when I try to download to any port, it returns “Unknown Device id (0)”. COM3 is the correct port, as any other returns the “hold down the PROG button” message, but to download anything, the computer still needs the controller to go into download mode.

Did you follow the instructions provided with the Master Code (in the zip file). It explains how to verify the correct COM port?

Finding the correct COM port is not the problem. On my laptop (Linux), there’s a device that’s created specially for the loader, so there’s no chance of getting the wrong one. On our Windows computer, when I connect to COM3 and verify, the microcontroller beeps a little bit, so it has to be that one.

I suggest you call our tech support line at 903-453-0802 with the system connected in front of you. We can do some trouble-shooting over the phone and then issue a RMA Number for the return of the unit if necessary.

Diagnosis - Dead serial converter, probably the VEX specific box. David brought his programming cable to robotics today and it worked fine. I will try the tech line the next time I’m home during operating times, thanks for the tip.

**The Programming Light could have a problem or the VEX Controller is not getting commands from the Programming Module. Right now the problem could be anywhere from the computer to the Controller. Maybe you can use someone else’s computer with the IFI Loader to help troubleshooting the problem.

You can always call us (903-453-0802) for an RMA Number for the return and repair if you need to.**

No, it’s confirmed, it’s the little VEX box that sits between the Prolific adapter and the controller. The button does nothing, but using my Prolific cable and another box works fine on two different computers. The same symptoms occurred when I tried using the defective box on other microcontrollers, but the working one works universally. There’s something more wrong than just the button not being connected, as the MCU not being in program mode would result in picloader crashing 3 data blocks in (tested it), but with the broken box, the load continued with no indication of an error on the computer side (IFI Loader showed nothing either). I have already contacted VEX to ask about possibilities of getting it replaced.

So the VEX Microcontroller is not getting everything it needs from the Programming Module. I suggest you purchase a new Programming Hardware Kit (276-2186) unless the kit is under the 90 day warranty. If thats the case, you can call us (903-453-0802) for an RMA Number.