Answered: tether failure

I am going thru the new user guide algorhytms, and at step 1 - doing a ‘hard tether’ the units do not pair. The joystick vexnet LED is solid green, but the controller vexnet LED is blank.
When I tried to tether them with the vexnet keys in the joystick vexnet LEd is a rapid blinking yellow, and the controller vexnet LED is a slow blinking yellow, while the LED for the robot is a slow green blink and every fourth blink all 3 LEDs blink red.
Any ideas?

dave,

In order to use the VEXnet Keys you must successfully tether the Cortex and Joystick first.

When teathering:

  1. Connect Cortex to Joystick with the USB A-A cable
  2. Power on the Cortex
  3. At this point, if you look at the Cortex you should see blinking orange LEDs on “VEXnet” and “Game”
  4. After a little while the Cortex and Joystick will tether, this will be indicated by green LEDs on “VEXnet”
  5. If successful, try the VEXnet keys
  6. If not succesful, try reloading your Mastercode & Firmware (let me know if you need help with this)

I downloaded mastercode using the Vexnet Upgrade Utility ver 1.2.3 on both the joystick and the cortex: It took several attempts to get it to download successfully - I had to hit the config button while connecting the USB cable on both and do this several times before the download would complete. The Master code number on the cortex was 2.81 while on the joystick it was 2.41 - if this makes a difference.
After the above I tried the ‘hard tether’ and again the LED for vexnet, on the cortex was blank, while the other 2 LED had rapid blinking green lights; on the joystick the vexnet LED has a steady green, the the robot LED is blinking green and the joystick LED was red. LED remained the same after connected for 5 min.
Your last post said to download mastercode and firmware. I used the Vexnet Upgrade Utility - but this only downloads mastercode, is their a second download to do for firmware?

dave,

The two blinking LEDs on your Cortex (Robot & Game) mean that your unit is in a download state. I would recommend you run your Cortex though the VEXnet Upgrade Utility again, and make sure it downloads successfully (see attachment).

Also I meant to say download Mastercode & Usercode (default code).
Which upgrade Utility did you used, the one from easyC or the one listed in the VEX website?
If you used the one from our website, the default code should be downloaded automatically; however, if you used the one provided by easyC you will need to do the following:

  1. Connect Cortex to PC
  2. Open easyC
  3. Click on the “Build & Download” tab
  4. Click on the “Downlaod Default Code” option
    Up to date.jpg

When I connected the cortex to the PC and ran the Vexnet Upgrade Utility version1.2.3 it reported the Vexnet was up to date Noaction required. I had earlier gone to the downloads page and downloaded the latest version of the Upgrade Utility, but I don’t know the designation (for example version 1.2.7) for it, to know if it successfully downloaded. Currently I have 2 VEXnet Upgrade Utilities-version1.2.3 and version 1.2.3(OEM).Also currently when I open the easyC tab, listed are 5 programs: easyC for Cortex, easyC help, IFI VEXnet Firmware Upgrade, intelitek Loader, and VEXnet firmware upgrade utility. The IFI firmware upgrade and Vexnet firmware upgrade utility programs seem to do the same thing, Should I use one vs the other?

When I ran this thru the easyC program,build and download tab, their are 2 options, easyC default code and IFI default code, both downloaded successfully but I downloaded the easyC default code last.
After doing this download the cortex LEDs -while attached by USB cable to the PC had following pattern: robot-solid red,vexnet-solid green,game-rapid blinking yellow. When I disconnected cortex from PC and turned it on this is the LED pattern: robot-no light, vexnet- double blinking red,game-no light.
When I did a hard tether of cortex and joystick LED pattern on cortex is: robot -slow blinking green,vexnet-solid green,game-no light. On the joystick the LED pattern is joystick-solid red,obot-slow blinking green, vexnet-solid green.
When I put the VexNet Keys in and powered both, I got the following LED pattern: cortex, robot-slow blinking green,vexnet-rapid blinking green,game-nolight. On the joystick, joystick-solidyellow,robot-slow blinking green,robot fast blinking green.
AFTER doing all of the above my son wrote a quick program with easyC and it downloaded and ran! Hope you can take the time to answer the questions in this post, but want to thank you for your help.
I apologize for the length of this post, but I am getting dejected at the lack of success and my 15 year-old is losing his interest.

dave,

You reloaded Mastercode & user-code successfully, also you were able to obtain a good wireless link with the VEXnet keys… so it sounds to me like you are actually doing pretty good.

As for your questions:
There are a few different versions of the VEXnet Upgrade Utility Tool. I would recommend you to always use the VEXnet Upgrade Utility Tool provided by your software manufacturer (easyC by Intelitek). As you mentioned before this tool can be found if you follow this steps:

  1. On your PC click on “Start”
  2. Click on “All Programs”
  3. Click on the easyC folder
  4. Click on “IFI VEXnet Firmware Upgrade”

When trying to download default code directly from easyC, you will notice there are two different kinds of default code, easyC default code & IFI default code.
The only difference between this two codes is that easyC default code controls all the motor ports in the Cortex, while IFI default code only controls ports 1-5.

I apologize about the frustration, and let me know if you have any more questions.
Thanks.