Answered: VexNet dropping connection / Cortex resetting?

Hi, we’re having a problem where our vex robot loses connection. We had a competition this weekend where the robot dropped connection repeatedly in almost every one of our matches. It is intermittent since we did have 2 matches where it worked for the entire match. We’ve been able to reproduce the problem at home now though not as reliably as in competition.

Here is the sequence:

Power up the robot:
Robot Game Light - yellow fast blink
Robot Vexnet Light - yellow slow blink

Some seconds later:
Robot Game Light - Yellow fast blink
Robot Vexnet Light - Yellow fast blink
USB Key - blue light comes on

Turn on Joystick and connect:
Joystick robot light - Green slow blink
Joystick Vexnet light - Green fast blink
Robot robot light - Green solid
Robot Vexnet light - Green fast blink

Sometimes immediately after connection (i.e. before you can do anything with the controls), or sometimes after driving for a few seconds:

Joystick - all lights flash red very quickly and the joystick appears to start its sequence over
Robot - slow blinking red vexnet light

Here are things we’ve tried to do to fix the problem:

  • Verified that we have a fully charged backup battery installed
  • Fully charged robot batteries
  • Tried a test with the cortex wifi key on a USB extension cable, even moved a couple feet away from the robot (actually seemed worse)
  • Tried using a different joystick (paired the new joystick with the cortex)
  • Tried exchanging wifi keys with another team
  • Used a USB tether cable to the robot and was able to operate the robot continously.

From the Cortex manual, the joystick flashing all lights red would indicate a reset (I assume of the cortex or does it mean that the joystick reset?). The slow red blink of the cortex vexnet light indicates “Fault: User Microprocessor Issue”.

Our code is a very simple EasyC program, no autonomous and only a few blocks; an arcade drive block and a few joystick to motor blocks, no logic, no loops other than the main “while (1)” loop.

Any help you can provide would be greatly appreciated! We have another competition in 2 weeks.

Team 918


First we need to make sure you have the most current Master Code on your VEXnet system.

Please upgrade the Master Code to version 3.1.6


Ok, looks like the master code might have been out of date since it is updating now. However, is it supposed to take a really long time? It has been downloading the master code to the cortext for 15 minutes now. The game led is blinking very fast and the robot light is slowly blinking so it looks like its doing something. However on the windows side, the update application is not responding. It’s last UI update shows “Writing Sector 8”, on the file “Cortex_v3_16.bin”.


No, it should not take that long.
Call our Technical Support line for step-by-step instructions on this procedure.
Here is our contact information:


Ok I got past the firmware updating. I had to try several times but then I got the slow red light blinking while it actually made progress downloading.

Tonight I was able to get the latest master code downloaded into the cortex and joysticks and the robot is still not functioning. I first used the innovation first downloader and then when I got the latest version of EasyC it had an even newer version of the firmware so I downloaded that. Updated joysticks and cortex, re-downloaded the program, re-paired the joystick to the cortex. No luck.