Answered: Vexnet Firmware Upgrade Utility does not work.

I cannot upgrade the firmware using this utility for either a cortex controller or a joystick. Used the utility installed with latest EasyC for Cortex (v Using utility 1.1.7. And tried the version on the Wiki

Downloaded zip from Wiki and followed instructions to the letter for Cortex, just in case something is/was wrong with utility installed by EasyC. Green LEDs do as indicated upon connection to PC. Utility never shows any message in message window after “Connect a VEXnet Device Click Search” as indicated in the pdf instructions, it just goes blank, for either the controller, or the joystick…The process fails at step 9 on page 10/17 of “Vexnet Firmware Upgrade Utility Operating Instructions.pdf” The utility never shows “Update Firmware Click Download Now”. A download attempt freezer a little over half-way. Then I get a critical error telling me to reboot. I’m tired of rebooting. I’ve done it a dozen times looking for a pattern, or something to ID as the cause. I’m about as frustrated as I was last year when VEX introduced the VEXnet upgrade, with its ‘issues’. I was hoping to get beyond this by trading all that ‘stuff’ in…

LEDs on joystick or controller never blink red as indicated in instructions.

If I reconnect the USB keys and use the download window in EasyC to “Get Vex System Info” it says joystick firmware is up-to-date with a green check mark, but utility says nothing. Sys info says controller firmware version 0.0, but linking the joystick and controller via Vexnet executes the ‘default’ control program.

I’m using WinXP. There are not multiple copies of the ushidio utility running. Obviously without this upgrade I cannot download any new program using EasyC.

What’s next, an RMA? or do you have an update for the utility?

Yes, you are correct – RMA is next. Please contact Tech Support at 902-453-0802 for a RMA Number to return the units or you can email me directly at I would return the Joystick and CORTEX.

After investigating further, by trying the upgrade on another PC with the same joystick/controller/USB cable combination, I’ve found its NOT a problem with that hardware, but with the first PC.

I’ve got 3 sets of joysticks/controllers and on the 2nd PC the upgrade utility worked just as described in the pdf document.

I’m going to continue to work to determine root cause of the problem. Try to find out just what the issue is with the utility running on that particular laptop. Any assistance or diagnostic tools/methods you might have or know of would be great. I will share what I find out.