Arm Only Moves Sometimes

I have two blocks of code that make the arm and claw on my robot do different things. In the block of code where the Arm Motor spins up first (directly under the when started hat block), the arm and claw both work. The second screenshot of code has the arm moving after the claw. Regardless of what block of code I use to move/spin the arm after doing anything to the claw, the arm motor does not work; however, it always works if it moves before the claw.

Can you please help? I am wondering if there is a problem with powering the arm after powering the claw. I am at a loss otherwise.


1 Like

Does the claw make it to 120 degrees? If the motor never reaches the destination it will hang the program. Unless you have a ‘set time out’ setting first which tells the move command to give up after N number of seconds.


Thanks for responding. I believe the claw reaches 120 degrees. I am going to try just spinning the claw open and/or setting a time out today when I see my students.

1 Like

That and your arm doesn’t have a set distance to spin so correct me if I’m wrong but it will either spin forever or barley spin at all.

If you want to make the arm motor finish spinning before the claw motor starts, use a wait or wait until block, etc.

It has nothing to do with the timing of the arm motor. The arm motor didn’t work if the spin block was after the claw motor block regardless of waits, breaks, stopping the claw motor. I think we may have figured out why, but we have another problem. The claw motor opens the same amount regardless of degrees. Opening the claw motor 1 degree is the same as opening it 20 degrees. That sounds like a sensor/motor issue., but I"m not sure. Thoughts?

The arm will go all the way up or down if it doesn’t’ t have a distance.

1 Like

This is the mostly likely scenario. It’s never getting to the “spin up” command. The claw is likely hitting a mechanical stop that is preventing the 120 degree target.

Try pressing the arrow at the end of the “clawMotor” block to expose “and don’t wait” - this will make this command non-blocking and you should see the desired behavior.


If that doesn’t work, sending a video of the problem will help us find the solution.

1 Like