"Attempt to reconnect failed - check hardware"

whenever i try to upgrade the firmware on my cortex or controller, the program says: “Attempt to reconnect failed - check hardware” after loading 90% of the way, how can i fix this?
I am using: VEXnet Upgrade Utility V.4.1.2
EasyC version: 4.2.1.7

Thanks!

I would try basic things like different cables, removing batteries, other computers, and or multiple attempts of upgrading. Had simmiliar issues resolved by repetition sorry for the lack of technical response only a suggestion.

I got it to work by using a different computer, I think the virtual machine on my first computer might have screwed something up

Trying to upgrade master firmware from a VM is very unreliable, it nearly always fails when I have tried in the past. You need to use bootcamp (assuming you are on a Mac) or find a real PC.

We have seen this issue many times. We have solved it by using one or more of the following strategies:

  • Completely rebooting the Windows PC used for the upgrade.
  • Replacing the USB cable with a different one.
  • Holding the cable steady during the transfer.
  • Trying the upgrade with the battery on, then retrying with it off.
  • Downloading the default code, followed by the latest code.
  • Simply retrying the process several times after the aforementioned steps are taken.

The most effective step seemed to be rebooting the PC – the USB ports sometimes get confused when you upgrade a Cortex, then switch to a joystick or Vexnet key. Good Luck!