Autodesk is downloaded but it won't open

Alright, so I have been using Autodesk inventor 2017 for a few weeks now, just fine. But a few days ago I got on my computer (using Windows 10) and tried to open Autodesk but it brought up an error box that said mcf140u.dll is missing from my computer. As far as I know I didn’t mess with or delete this file. I then went to windows and opened up the autodesk file, and was able to find that mcf140u.dll file.

Have you tried restarting?
Otherwise you might be missing some C++ packs.

Yes, I have tried restarting multiple times(sorry I forgot to mention that). Do you know where I can download individual C++ packs?

Do you mean mfc140u.dll, I do not believe a mcf140u.dll exists?

If so, I have include the ZIP files of this dll file. There are different version for 32 or 64 bit windows, so choose the appropriate one. Then unzip the dll file and place it in the windows/system32 folder.

FYI, I checked and I do not have that particular dll file and I use Autodesk Inventor with no issues. However, I use 2016, not 2017. (2.26 MB) (2.53 MB)

Thank you!!! The differing versions actually do have different files I found out (I have 2015 on a different laptop and its files are way different then 2017’s)

Well I tried copying the file to my computer, unzipped it, put its contents in the right folder (I went to Windows -> Autodesk -> Inventor_2017_English_Win_64bit_wi_en-us -> setup) but when I copied it I made sure it was the only file in there by that name, tried to open Autodesk and it still didn’t work. So now the question is how do I repair this (this being the fact that Autodesk is skipping over this file that is crucial to its startup for no apparent reason).

If you are talking about the DLL file, it doesn’t go where you specified. It goes under C:/window/system32

Oooohhhhh. That shows you what I know.

I finally got it to stop saying that something is missing from my computer but now it’s saying that “The application was unable to start correctly (0x000007b). Click ok to close the application.”

Here is a website with some things to try. It is for a slightly different error code, but I believe it may be your problem as well.

Here is a video showing how to do one of the methods.