Autonomous issue with turning

When coding our autonomous I ran into an issue. When the code reaches the highlighted command it infinitely starts turning left. What’s wrong?

Can we see how your drivetrain is set up? And if there is an inertial sensor, is it in the right port/ is the inertial sensor’s port glowing a solid red?

1 Like

I don’t have access to the program at the moment. It’s just a 4 motor drivetrain. It’s coded through the devices tab, not the actual code. We don’t have an inertial sensor so that shouldn’t be the issue.

Ok, have you tried modifying the values of the turn (like using negatives and such) to try and debug the problem?
Another thing I would try is running a program where the auton is just the turn command and see if it works, or trying different types of the turnfor as shown in The vexcode API


If you are not using an inertial sensor for turns, the drivetrain class uses the geometry you provide it to attempt to make the correct turn. I have found the need to input arbitrary numbers for track width and length in order to make turns work. Think of those numbers as knobs to adjust in order to make turns accurate.

I would suggest (like @7996B )making a program that only turns and editing the track and width to make it work. I have had teams need to use numbers that are 1/10 of the measured distance to keep their drive from spinning multiple times when they called for 90 degrees.