Autonomous Motor Not Working

We were working on our autonomous programming and one of our motors stopped working. We tried using it while driving and it worked just fine, and we have other motors programmed the exact same way that work just fine as well. We have changed the programming and nothing has worked. Has this happened to anyone else?

I’ve not had such an issue. What command are you sending the motor? Are you sending that command in the autonomous section of the code? Are you using a comp switch or the controller’s build in skills run feature to trigger autonomous?

Could you post your autonomous code in this thread? Which IDE (Vexcode V5, Vexcode V5 Pro, Robotmesh Studio, PROS) are you using?

1 Like

We are using VEXcode V5 Here is the programming we used

I’ve never used that before, but it looks like it should work. How are you triggering the autonomous code to run? Competition Switch?

1 Like

We are using the completion switch

do other motors work during autonomous? I see you ask the motor Motor_Claw to spin, does that work?

1 Like

The other motors do work the claw is the only one that doesn’t. No, the Motor_Claw to spin doesn’t work.

Ok, and the motor_ring_holder works as well? Can you check that the motor port that is being used for the claw is the same in the robot as the code? Also, could you check that the red light coming from the cable port on the motor is on and solid?

1 Like

Yeah, the motor_ring_ holder works, The red light is on and solid.

I’m not sure if I was clear, I meant the cable port on your claw motor. Does the claw motor work in driver control?

1 Like

Yeah, the claw motor works in driver control

I’m not sure where the issue is, then. I wish you luck :slight_smile:

1 Like

I am the coach. This is a very confusing problem. I’d like to point out that we have replaced each part of the system, the smart wire, motor, and the brain. When we plug the claw into the port for the ring arm, the motor works, but then the command to run the ring arm doesn’t work. We are using the same block to run the ring arm and claw, just telling it to move a different motor. It seems to be the block that is causing the problem, but it’s the same command we are using for another part of the autonomous program that does work. Any help is appreciated. Thanks!


See if using the wait until will fix it
It should look like this at the end of the block

Wait until

What do we make it wait for. It says ( wait until ___)

wait until claw motor is done?

1 Like

Click the

And dont wait

At the end of the claws moving block. Might fix a overriding issue that I see

Thanks, but that didn’t work either

Check the claw and see if anything is blocking its movement or if the motor is detached?