Autorun not right

Updated to ver.1.14 and RobotC 4.40 and found that the Autorun program is not working right, random is OK, spiral runs backward, and lawnmower just slowly rotates.

RobotC 4.30 right? Maybe typo.

Yes, typo and Edit is not working.

Hi whitepass,

We’re sorry that you have encountered this problem. The Lawnmower mode uses the Distance Sensor to detect walls and initiate the 180 degree turns before hitting them. There are two possible reasons that will make lawnmower mode appear to spin in place:

  1. There is something always in front of the Distance Sensor, such as an extra loop of Smart Cable, that is causing the robot to always see an object right in front of it.
  2. The Autopilot robot is in too small of an area to run well (it’s always too close to a wall, so it’s always trying to turn away).

Please check and make sure no parts of your robot are in front of the Distance Sensor, and that your robot has at least one meter / three feet to run forward before it would hit a wall. If you are still having issues with Lawnmower mode in Autopilot after checking both of these items, please check if the Distance Sensor is working properly.

To do this, please exit Autopilot program and go to the Home Screen > Settings > Device Info screen and scroll down to the port that the Distance Sensor is on. This screen will show live distance measurements from the Distance Sensor. If you move your hand between 100-300mm (4-12 inches) away from the sensor, the readings shown on the Robot Brain LCD will reflect this.

If this is not the case, or if you have any additional questions or concerns, please feel free to contact VEX Technical Support at support@vex.com or by calling +1-903-453-0802.

Regards,

  • Art