Battery not charging

For some reason my VEX iQ brain battery is constantly flashing red when charging and doesn’t appear to be charging at all. Any ideas anyone? Thanks in advance M

No idea… but since you are talking about batteries here is something the kids have been doing with their batteries to expand the battery life. The robot does not responds the same on 3/4 battery, but it is not recommended to charge over and over again and not letting it just consume all its energy before charging it, they have a light bulb with some wires they connect to the battery until the light bulb turns off. When the battery has no more energy they charge it again.

Aloha,
I’ve worked with a lot of batteries over the years with multiple robotics platforms. This problem , assuming the battery is older and used for many competitions, sounds like it reached that point of time to retire the battery. One trick that our team did find about the use of Brain batteries is that the robot seems to work much better if we take a nice and warm battery straight off the charger and go immediately to competition. It works for Krispy Kreme doughnuts and it seems to work for our batteries too. We used to charge them and then place them on the side to use later. But the freshly charged ones always seemed to work better.

  • Bailey

There has been posts about batteries that were “too dead to charge”. I know people have found ways to jump start them (charge them a little, using another method) and then put them on the charger and they charge OK.

I have no suggestions on how to jump start them.

Steve

Hi mariovex,

We’re sorry that you have encountered this issue. For additional assistance on this matter, please contact VEX Technical Support at support@vex.com or by calling +1-903-453-0802.

Regards,

  • Art

Bailey,

We also use the Krispy Kreme method during competitions. Also we have noticed that you can charge a battery and leave it without use for 3 days and when you try them, they don’t have much power. Our batteries last 2-3 good runs, afterwards consider changing it cause the robot won’t perform as well.

We found a suggestion on the forum that seems to have worked for many of our flashing red batteries. We “jump start” them by attaching them to a brain, along with a motor and gear. By spinning the gear, it sends a small amount of energy to the brain and it briefly lights up. After a few spins, the battery will usually be able to take a charge. This is especially useful with batteries that have not been used for a while.

Awesome, never thought of that.

Thanks, I’ll try that.

I had the same issue with some batteries. I took an old PC and pulled out the 5v and 3v wires from the power supple, taped them up, plugged it in, and 15 minutes later we were good to go.

I have successfully done this, and will relate what I did, but PROCEED AT YOUR OWN RISK (and GET AN ADULT TO HELP)…

I used a 12V car battery charger (8-10A setting), and very briefly touched the clamps to the battery terminals (maybe 2-3 seconds maximum contact time). Then, immediately put the battery on the IQ charger and let it charge. In our case, the IQ charger turned green awfully fast (somewhere between a few minutes and 30 minutes - I don’t remember), so we took the battery off and let it sit for a little bit (5-10 minutes?), then put it back on the IQ charger. At that point, it fully charged in a few hours like normal.

YMMV, but I hope that helps.

I can confirm that JJTar’s suggestion worked.
Thanks for that.

Add me to the JJTar fan club, I just pulled two back from their red-blinking grave…

Hi, I got the same issue, and tried the spin motor method, the brain briefly lights up indeed, but the charger still blinking red with the battery plugged in, any suggestions?
Thanks in advance.

Hi ken,

We’re sorry that you have encountered this issue. Please contact our technical support folks at support@vex.com or by calling +1-903-453-0802 so we can provide additional assistance to resolve this situation.

Regards,

  • Art

Try this at your own risk, it worked for me.

Put the battery in a zip lock bag, and put it in the freezer overnight. Place it on the charger. You may get a green light after a few minutes. Take it off the charger, wait a minute or so, and put it back in the charger. After a couple of tries the battery took a full charge, and has been working fine ever since.

JJTar solution worked like a champ. We have 8 kits and 5 of the batteries were flashing red after sitting for a year. Did the motor jump start trick (bout 10 turns on motor) and bam, all 8 batteries work now.

I haven’t used my Vex IQ for a while and battery refused to charge (flashing light). I used my voltage generator (or any 7.2V charged battery) to “jump start” the Vex battery.

Just connect same polarity terminals for short time (couple seconds) and then try charging again. It did the trick for me.