Battery Stuck in Bootloader

Hi @jpearman ,

One of our v5 Batteries is flashing in a 1,2,3 pattern. The whole sequence happens about 3.3x per second.

000
00G
000
0GG
000
GGG

The red light is also flashing, but at a slower rate, about 4x per second. When we unplug from power, it alternates red and green quickly. Plugging into a brain slows the flashing down, but after a couple of seconds the brain turns off. We have tried with a couple of different brains, and both behave the same.

When we connect to battery medic, we get the following:

If we plug the battery into the brain whilst it is plugged into the charger, the brain displays a banner at the top “Waiting for Download…” but then disappears after a few seconds.

We have tried force-updating the brain firmware, but no success.

Obviously this is supposed to be an automatic process, but something isn’t working. Is there a way to manually force a firmware update to the battery?

date     : Fri Feb 11 2022 14:54:24 GMT-0800 (Pacific Standard Time)
version  : V5 Firmware Utility 1.3.0
vexos    : 1,1,0,0
Serial   : VEX Robotics V5 Brain - 9F0B2800:/dev/tty.usbmodem143101
CPU0     : 1.1.0b1
CPU1     : 1.1.0b0
Assets   : ok

arch     : x86_64
platform : mac
release  : 18.7.0
cpus     : 4
model    : Intel(R) Core(TM) i5-6287U CPU @ 3.10GHz
memory   : 16777216 KB
agent    : 5.0 (Macintosh; Intel Mac OS X 10_14_6)
         : AppleWebKit/537.36 (KHTML, like Gecko)
         : Chrome/67.0.3396.87 Safari/537.36

Devices  : 
  port 22 : V5 Tri Port             (Type 12) version: 1.0.0.b9  boot: 1.0.1
  port 23 : V5 Battery              (Type 14) version: 0.0.0.b0  boot: 0.0.0

Programs : 
  No programs !

-- Local Cache -------------------------------------------------------------------
VEXOS_V5_1_0_6_0:0
VEXOS1_V5_1_0_8_0:0
VEXOS_V5_1_1_0_0:0

No, you would need development tools for that.

Have you tried another battery cable ?

If all else fails, I guess this is a legitimate time to push the hidden battery reset button (inside the small hole) and try plugging into the brain again (with the charger connected).

5 Likes

We have tried another battery cable, and another brain.

We have tried pushing the reset button also.

Can the development tools be made public? Or at least a version with the subset of functionality which allows this?

No, and it sounds like they probably would do anything useful anyway. The only way to update the battery is via the V5 brain, and it sounds like the brain tries and fails.

2 Likes

So it’s just bricked?

I can’t say for sure, but it looks that way.

Did it fail during an update or just do this on its own ?

If it’s fairly new, try giving vex support a call (you could try that anyway) and explain what happened. If you get nowhere with that and plan on be at the world championships, bring it with you and ask VEX tech support to have a look and see what they can do.

4 Likes

We had been using it just fine, then we plugged it into the brain after a charge, and it said it needed to update the firmware. It tried, and then failed. Since then it’s been like this.

It’s a couple years old, but yeah we will bring it to worlds, thanks.

1 Like