Battery Suddenly Dies

With our robot when we try to pickup multiple stars the weight makes the battery drop and the robot cortex light goes red. But we still have some power. When we plug into the computer it says we have a perfectly fine battery with a good battery.
Thanks for the help.

Is it possible you’re browning out the controller, by drawing too much current through your arm motors? If you add more motors to the arm or lower the gear ratio, does the problem go away?

Sorry if this may be irrelevant a little bit, but does your CORTEX also has a 9V battery?
I may have some lists that you may have an issue with:

  • There can be a chance that the connection of the plugs between the 3000 mAh battery and the CORTEX isn’t reliable which results in the 3000 mAh battery disconnecting even when plugged in, and the 9V battery kicks in trying to provide power. This happened last year, during regionals when our robot lost power due to an unreliable plug on the battery, which meant we couldn’t move during the whole time during the match.
  • The Cortex while plugged into the computer is getting power from the computer…
    (To ensurely know if the battery is fine or not, on ROBOTC, try going to Robot>Advanced Tools>Software Inspection and check if the robot has a good battery.)

Right off the bat I will just assume you have a 9V battery and that the metal inside of the CORTEX’s female plug is messed up and is pushed back which results in the CORTEX losing power by a jolt or vibration. But I may be wrong…

This helped a bit the light no longer goes red it goes yellow but right after you turn it off and back on the robot goes back to green. we plugged in a 9v brand new

Cortex Master CPU Integrity: Value Status

Firmware Version: 4.25 Up to Date
Main Battery: 7.5V Good (>6.5V)
Backup Battery: 9.0V Good (>8.7V)
Team Name: "CT " OK

This is not it because we currently have 6 motors we used to have 4 motors and the gear ratio was higher.

Okay, For the female battery plug for the CORTEX, I want you to check if you are able to see the metal pieces in them…

I just checked there’s nothing in there plus its a brand new cortex.

I think I said it wrong, do you see those metal ‘rings’ on your cortex?

yes there is nothing blocking them or in side of the ports.

Ok so the main battery should be 7.0 or 8.3 (maximum) for the light to be green. I think you should try different batteries. Or you should use a battery extension cable.

We have tried multiple batteries and they are all NEW we got brand new batteries in the last week.

If everything is working, I’d ignore the lights. If you have a very strong draw on the battery, the cortex can indicate the battery is dead/dying because the voltage suddenly drops, even if it’s still perfectly fine and has lots of charge. Our robot last year liked to do that. After just a few minutes of use it would go yellow but could still be used for much longer without any affect on performance.

@Kevin Boenisch
When the light is red we are unable to lift more then one star.

My guess is it’s probably due to the PTCs in the cortex tripping at the same time the cortex is tricked into seeing the battery as dead. Have you optimized the lift with rubber bands to reduce the strain on the motors? Have you distributed the motors of the different ports in the cortex and power expander?

You may need to deep cycle the batteries, just as a shot. We got 8 new batteries last year that did the exact same thing, sent them back.

There have been a lot of wild guesses here. What you are describing sounds almost certainly like the motors drawing too much current when raising your lift and causing the voltage to drop (as Kevin said here). This is not uncommon when you are working on the edge of your power limits, especially with older batteries.

Do as Kevin said and try to make things easier for your lift motors.

Can you give me the specs of your robot. It would be more useful. What is your ratio? Are you using a power expander? Have you tried using a different cortex? All of this info can help us figure out what your problem is.

I think we have figured it out, just wanted to thank everyone that helped out.