Battery Update Fails

Hello, after updating the V5 brain to the latest version it asked for a battery update and after plugging the battery in and starting the update it gave this error. I shut down the brain and retried multiple times.

have you tried updating the battery from a different brain?

1 Like

I have not, I can try that tomorrow.

1 Like

Did the lights on the battery start flashing ?

We have not had a battery update for over two years. What was this brain running before the update ? I assume 1.0.8 or even earlier. Try a different battery cable, that may help (you could also run the battery medic to check what firmware the battery has, I assume it’s not an old battery left over from the beta test systems or anything like that).

5 Likes

I tried switching the cable and this time it started the update. While on the Waiting for Download... screen it showed the same error message as it did previously: The download terminated due to a hardware failure. After seeing this message I shut down the brain and restarted it and the battery flashes like this very quickly(the firmware error pattern) when the brain turns on:


After the brain turns on it gets in a loop and keeps displaying the Waiting for Download... message while the battery slowly alternates red on the left and green on the right which indicates it is loading firmware. It looks to me like the brain is stuck in a loop loading the firmware to the battery. We tried the battery with another brain and the same thing happens.

Not sure what to suggest really. I did a sanity check and downgraded a system to 1.0.8 (along with power chip and battery firmware) and then did an update to latest vexos, 1.1.0. The power chip updated correctly and then the battery did an update, so there’s no systemic issue (at least going from 1.0.8 to 1.1.0). Most likely cause is bad/dirty connector or cable. Your battery is stuck in the bootloader now as the update failed, so the brain will try and update it every time you connect.

3 Likes