Battery Won't Power Brain - Status Lights ok


I have a brand new V5 kit that after charging the battery won’t power the brain. Other batteries power the brain - and I tried the failure battery on several brains.

The status lights are all fine and seem to act like a working battery.

When I try to power the brain, the status lights tun on like normal, so it receives the signal but a brain won’t actually power up.

Any ideas?

Unofficial Response
Did you verify that the charger that charges the battery is plugged into an outlet? As in when you plug in the battery to a charger it blinks.

1 Like

Yes. It was 3 solid green and the 4th blinking green while charging.

Update: I plugged back into the cahrger and after a while it went to a slow flashing red LED occurs once per second. I unplugged it and the error seems to clear. Pressing the button has it display 4 green lights.

Have you tried hitting the reset button?

1 Like

You might have a bad cord. It happened to me when we first plugged in our brain to the battery

Not the battery cable - I used the same cable to power up the brain with a different battery.

I would recommend to call vex support, and see what they say.