Behavior of remote control different than autonomous

Hi,

Our kids have built a robot arm that can hold 4 balls. When they use the remote control, they are able to move the arm easily with the weight of 4 balls. But when they try to do the same within the autonomous code, the arm struggles to move due to the weight of the 4 balls ( without the weight, the auto code moves the arms fine )

Question is - why does it work under weight using remote control but not autonomous.

here is the code:

moveMotor( Motor10, 3, seconds, -100)

They tried with Seconds, Rotations as well as change the speed from -50 to -100 etc.

Please advise!

Thanks

The top motor speed, in the negative, is -128, so at -100, they are only using about 78% of the motor’s power. Trying changing the motor speed to -128, and see if it will work then.

On a related note, the top motor speed, in the positive, is 127.

With VEX Cortex, this is true - the maximum and minimum values are 127 and -127. However, with IQ the help file for ROBOTC states that the values are 100 to -100. Is the current limit set lower by default? Try including the line:

setMotorCurrentLimit(motor10, 3723);

3723 (or 3.723 Amps) is the maximum that ROBOTC can allow to each motor. Not sure if this just sets the flag limit or whether the current is physically limited as well but worth a try.

Edited to add:
Ignore all of that, I guess you are using graphical which doesn’t give you any control over current limits anyway I don’t think. And, I have done some quick tests and the current limit only seems to affect the flag and not the actual current available so doubt this is your problem.
However, I did check the debugger and even if you set an IQ motor to 127 power, it only receives 100 according to the debugger so I don’t think this is your problem either.
Do you only have one motor on your lift?

Seems like some type of power issue…

Are there other motors that are moving at the same time as the arm when you are in Auton, but not Teleop? Are you performing this lift operation well into the auton routine, after many other commands have been executed (temporarily lowering the voltage on the battery)? To rule out these as possible issues, try writing an auton program that only includes the moveMotor command.

If the moveMotor command works fine by itself, then you will need to adjust the gear ratio of the lift. What’s the gear ratio now? Something slow and powerful is typical for a lift arm, like 1:9.

I’m with jrp. Some sort of power issue. My guess is that you’re driving a claw closed, and continuing to drive it in auto, but not when driving.

You may want to post the whole program.

Hi all,

Thank you all for your responses. A few points:

  1. We are using Vex IQ ( and not Vortex )
  2. The code we tried is graphical Robotc
  3. The code only contained 2 lines which was to test the moveMotor
  4. we found that one motor is not bringing the arm up so we added a second motor. With the second motor, the arm moves up fine with remote control but not auto.

Please advise.

Thanks!

Can you post your program for both remote and autonomous operation? For graphical ROBOTC, It’s best to upload the actual file incase there is problems with the configuration rather than the code.