Block code- turn does not stop

Coding in Blocks and now using the turn 90 degrees. The problem is - the robot does not stop at 90 degrees? Continues to rotate in the direction indefinitely. So the robot just spins. Using claw bot. what have we missed? Thanks in advance

Please post a screenshot of your code, or upload the file directly, otherwise it’s very difficult to debug code you can’t see.

image

Our team had the exact same issue, I felt like when we moved the gyro to it’s own section when assigning ports instead of lumped in with motors in the UI fixed it or something really similar. But not 100% on that, if you don’t get answers i’ll find out next Monday when we meet again and ask the kids.

So it is the last command that runs indefinitely?

Try putting a wait at the end of the program for 100 seconds. Just a hunch…

It is the last command only that is causing the issue. I have tried multiple changes to this one command line and the same issue. no matter the degree. I tried to put a stop motor in and that did not stop it either. I’ll keep trying other things and mixdared if you find out how your team solved this I would love to know. thank you.

Does the robot turn the correct direction ?
Is the gyro (assume you have a gyro) plugged into the correct port ?
Is the gyro mounted with the arrow on top (ie. did you for any reason mount the gyro upside down) ?
Check the gyro is working on the devices screen.

2 Likes

The robot turns left as instructed. The gyro is mounted correctly and connected to correct port. I checked the devices screen and I do not get an error. Also I clicked the check box and it calibrated the gyro. after all this the robot continues to turn left without stopping at 90 degrees.

I was unable to duplicate this issue, robot always turns left and stops as expected. Perhaps you could send me the whole project and I will try and reproduce again. Can you perhaps try another gyro and/or try moving it to another port on the brain.

2 Likes

I tried moving ports. was on 4 and now on 9. still same issue. I have a mock comp today with another team. I’m going to see if I can try their gyro as I only have the one. I’ll see if that works. thx.

Thanks all. I switched gyro and it worked. turns out I have a bad one. consider this solved.

3 Likes