Brain and/or Controller Failing

When I first opened up the Starter Kit and put everything together, the built-in firmware worked great.
After updating it, it took a turn downhill.
Now the right joystick on my controller won’t work at all.
I tried a different controller and had the same issue.
I tried switching out the motors, and the problem persisted.
I tried making programs with RobotC 4.0 and Modkit (not relying on the built-in program) only to encounter the same issue.
I tried different ports and it didn’t make any difference.
I tried using different wires and that didn’t work either.

At this point in time I’m thinking I have a hardware issue and/or that my controller/brain need to be reset somehow.
Any advice?

Hello Mike,

I apologize about your frustration.
I recommend you to calibrate your Controller, as this has fixed such issue before.
For the Calibration procedure, all you have to do is the following:

  1. Tether Controller to Brain (

  2. Press (X) on Brain

  3. Select “Calibrate Controller”

  4. Rotate thumb-sticks 360°

  5. Wait 30 seconds, and make sure the Brain LCD updates to the following values: 0,127,255

  6. Press (✓) to save

Let me know your results.