Brain - Error/Not Connecting

I have an email into support, but I thought I would post here in the interim.

We have three different brains, I am having an issue currently with one brain.

When we turn on the brain it says the following:

VEX Robotics Inc. DFU

Connect to PC for
Program Update


I have the brain connected to the computer with VEX IQ Firmware Update open. I have tried turning restarting the computer and the brain. I have also tried taking out the battery of the robot. I have tried multiple USB cords from our kits. The brain continues to say the message listed above. The firmware also does not show the brain as being connected.

Any assistance would be appreciated.



We are sorry that you are having this problem. The “DFU screen” (which means Device Firmware Update) is displayed whenever the Robot Brain is in firmware update mode.

This will occur in two instances:

  1. While upgrading firmware using the VEX IQ Firmware Update Utility, the Robot Brain will enter into DFU mode. The Robot Brain may temporarily get stuck in DFU mode if it is disconnected (such as USB comes unplugged) during the middle of a firmware update. This can normally be resolved by removing and reinstalling Robot Brain battery, restarting Firmware Update utility, then using the Update > Reinstall Current Version > Robot Brain option.

If the Robot Brain is not showing up in the Firmware Update Utility screen, please go to the Start Menu, then begin typing in Device Manager into the search screen. Click on this when it shows up in the search results. When the VEX IQ Robot Brain is connected, go to the “Ports COM & LPT” section and click the + icon to expand it. There should be a line called “VEX USB serial port” which is the Robot Brain. If this is displayed and there is a yellow exclamation icon next to it, there is a problem with the driver. This driver problem usually occurs when Windows replaces the VEX IQ driver with a default Windows driver. If this occurs, the easy way to resolve the problem is to uninstall and reinstall (using Administrator account) the VEX IQ Firmware Update utility.

  1. If both the Up and Down buttons are held down while turning on the Robot Brain, the Robot Brain will be forced into DFU mode. This mode can be undown by releasing the Up and Down buttons and power cycling the Robot Brain.

We have not yet seen any instances of a Robot Brain becoming permanently stuck in DFU mode that could not be fixed by following #1 or #2 above. If you would like additional support information, please contact our Tech Support folks at


  • Art

I have a similar but slightly different problem. I did the update to 1.17. Now when I plug the brain in I now get the message “One of the USB devices attached to this computer has malfunctioned and Windows does not recognize it.”

I did a complete uninstall of the VEX drivers and RobotC 4.08 and Modkit

I then did a full reinstall of the 1.17 system and it did give me the message about unsigned drivers and I clicked OK to install.

It had been working with Modkit before the 1.17 update.

Any ideas on a next step to get it back working? (It’s a WinXP Lenovo laptop)

Update: Spent some time and if I force load the drivers then I got it to work. So I have COM 18, 19, 20 to work with RobotC.