Brain not connecting to Vex Code IQ

I have connected my robot brain to the computer using the usb cord, but Vex Code IQ doesn’t show that it’s connected. The brain button is still white. I have a tournament coming up, and I would appreciate if someone answers soon. I have tried turning my brain off, pulling out the battery, and reconnecting the brain.

1 Like

Mac or PC ?
Is the IQ’s firmware up to date ? vexos

Try a different cable.
Try a different port of the computer.


Have you tried a different usb cable? I know that you can’t transfer data through some. Also, are you on a chromebook?

1 Like

If a computer doesn’t work, you could try an iPad or something similar. The same thing happened to me where wired connections didn’t work, but doing the (Bluetooth I think) with an iPad and the robot baron worked really well

It’s a pc, the firmware is up to date, and I have tried a different cable and port.

It’s not a chromebook. It’s a windows pc.

@jpearman Actually, it was the chord. Apparently I just had several chords that did not work lol. Thanks for the help!