Brain ports 1,2,3,6

I know there is alot of other threads on this but none have fixed the issue. So when we got back from worlds (students had a blast) we decided we wanted to have another team. We purchased a new super kit from vex. Assembled the robot and now I can not get the new brain to recognize ports 1,2,3,6,12. Checked the motors on the 1 motor port thats working. All the cables and motors work on port 7. Have tried the upgrade and downgrade of brain. Tried reboot of brain. Turning off brain and turning wheels will turn the brain on. Even robotc doesnt see the motors in debugging. Does anyone have any input on what to try next before we send this brain back? Any help will be appreciated. We would like to get robot working so the kids can start playing with programming.

Have you tried testing on the brain with everything disconnected first?
Disconnect all the motors and sensors, then use only one device for testing (using device info). You can try bumper sensor first, as it is still detected and exercises just a subset of the port’s capabilities.

I tried that with a motor. But can try again with a bumper.